web appbuilder developer app import fails

1368
9
Jump to solution
01-23-2018 10:26 AM
JayHodny
Regular Contributor

I have installed Web AppBuilder Developer 2.7.  I am working with Esri's public parking solution.  The 'Import App' fails to import this application.  Other applications will import.  The command window (log) shows no useful information (to me) as to why the application not import.  Also, if I use the 'Delete' on imported apps, does this delete them from my AGOL content?  Thank you.

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
JayHodny
Regular Contributor

Robert,

Tech support was able to help.  I downloaded the (zipped) app from AGOL to my desktop, and was able to import it from there.

Regards, Jay

View solution in original post

0 Kudos
9 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Jay,

   The public parking solution template is NOT a WAB app it is a esri configurable template application.

0 Kudos
JayHodny
Regular Contributor

Hi Robert,

Thanks for the quick reply. I am confused. I assumed it is a Web AppBuilder product, based on the screenshot.

Regards,

Jay

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jay,

   Sorry I am incorrect. It seems that the solution team has provided this as a WAB app. Do you know the version of the app that you are attempting to import?

0 Kudos
JayHodny
Regular Contributor

Hi Robert,

I don’t know the app version, how can I determine that? I was using an older version of WAB, and was receiving a ‘fail to import’ error. The error note directed me to upgrade to the most recent version (2.7) of WAB.

Thank you for your help!

Jay

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jay,

   Open the zip file and then the env.js file in a text editor. In that file you will find the deployVersion = '2.x';

0 Kudos
JayHodny
Regular Contributor

Hi Robert,

//This version number will be appended to URL to avoid cache.

//The reason we do not use wabVersion is to avoid force user to change wabVersion when they are customizing app.

deployVersion = '2.7';

Thanks,

Jay

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jay,

   Then it does not make sense why it won't import. I would get tech support a call.

0 Kudos
JayHodny
Regular Contributor

Hi Robert,

I agree. I can open other apps, but not this one. Thanks for your help.

Regards,

Jay

0 Kudos
JayHodny
Regular Contributor

Robert,

Tech support was able to help.  I downloaded the (zipped) app from AGOL to my desktop, and was able to import it from there.

Regards, Jay

0 Kudos