Signle Sign On for ArcGIS enterprise login support for Local Hosted WAB

2430
2
Jump to solution
04-30-2015 04:01 AM
BledarBirbo1
Occasional Contributor

Hi.

We have an enterprise arcgis online account with Single Sign On

I have created and downloaded a test application with Web AppBuilder Developer Edition.

When i access the IIS site the esri app asks for credentials. The problem is that we are using SingleSignOn on our enterprise AGOL.

Does Webapps created with webapp builder developer support single sign on ?

If yes please can you advice on how to enable this ?

Thanks.

0 Kudos
1 Solution

Accepted Solutions
BledarBirbo1
Occasional Contributor

Followed the Readme.html on the deployed site and it worked. Although the information was all over the place.

The key was to use a proxy.

View solution in original post

2 Replies
BledarBirbo1
Occasional Contributor

Followed the Readme.html on the deployed site and it worked. Although the information was all over the place.

The key was to use a proxy.

TheKenerson
Occasional Contributor

This helps. I am trying to do the same thing you are doing. I am sharing an app with an organization through a group. They don't have ArcGIS Online Logins, only Enterprise logins. 

When they log into the app they are prompted for ArcGIS Logins though.

I looked at proxies and I found good sources in YouTube, but proxies appear to be all or nothing from what I can tell. I would like the users to be prompted for a login because it is a secured service. I just want them to enter their enterprise login instead of their ArcGIS online login.

Any suggestions? 

0 Kudos