Should WAB Infographic widget work with time-enabled feature class Time Slider?

358
2
Jump to solution
06-07-2018 10:54 AM
BrianFausel
Occasional Contributor III

I have been trying to use the Web AppBuilder (WAB) "Infographic" widget (pie chart) in conjunction with the Time Slider. The web map display is working properly, but the Infographic pie chart does not update to reflect the time slider range. Am I doing something wrong, or is this not supported? Similarly, the "Attribute Table" widget does not reflect the settings of Time Slider.

Both the "Infographic" and "Attribute Table" widgets do work in conjunction with the "Filter" widget. They update as you set filters for the feature service.

I have tried this with an ArcGIS Online hosted feature service (with time enabled in the web map) and also with an older version of ArcGIS Enterprise feature service (10.3.1) where the time is enabled in the MXD. Perhaps it is supported on a higher version of Enterprise?

If this is not possible, I will need to log this as an Idea.

1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Brian,

   I don't see anything in the widgets code that takes into account the TimeExtent.

View solution in original post

2 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Brian,

   I don't see anything in the widgets code that takes into account the TimeExtent.

BrianFausel
Occasional Contributor III

Thanks for checking the code Robert. I have switched my strategy a bit and am now testing the real "Operations Dashboard" as opposed to the WAB "Dashboard." In there you can set the Infographics (pie and serial) to interact with a date range picker.

0 Kudos