Saving edits to web app in web appbuilder

2425
5
02-26-2016 07:30 AM
KarlKeough
New Contributor III

I have opened a webapp I built with web AppBuilder, made some changes and want to save them but cannot find a way to do so. On the bottom of the left hand panel is a banner with "Launch", "Previews" and "Saved". Next to "Saved" is an upward arrow with options to "Save" (greyed out) and "Save As" (see attached). I've tried saving as a different app but the changes did not stick. Am I missing something?

Karl

0 Kudos
5 Replies
RickeyFight
MVP Regular Contributor

Karl,

I would consider moving this to Web AppBuilder for ArcGIS

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Karl,

   This normally means that the changes you have made are already saved.  If you believe this to be incorrect then make a simple change to the apps title or subtitle and then save should be enabled, then you can change those strings back.

C_EHoward
Occasional Contributor III

I am having the same issue suddenly-- any app I have created has the 'save' greyed out. I can save as and create a new app with my changes but cannot make my changes apply to my current app. Saving a copy is a work around but not an acceptable one as I will now have to change my appID in multiple places.

0 Kudos
JulianoKersting
New Contributor III

I had this issue trying to edit a Webappbuilder App in which the ownership had been changed to somebody else.

This applies even if you are an administrator. You need to change the App's ownership to yourself, perform the App changes then change the ownership back is needed.

Even when the app is shared with a Group (created with the option to allow members to updated all content)

The steps I followed are:

1. Created a group “GROUP1” with the option “Members can update all items for this group” checked.
2. I have added a second user to the group.
3. The second used shared an application created in WebApp Builder with the GROUP1
      a. The App is not owned by me

      b. App id 1dbabb1c6b8044a39c27335fe5283c43
4. When I try to edit the app it does not allow editing.
      a.  No Edit option on the item details either.
5. I have also tried to use a direct link to webappbuilder with the App item id
   a. https://myurl/arcgisportal/apps/webappbuilder/index.html?id=1dbabb1c6b8044a39c27335fe5283c43
   b. The App opens in Webappbuilder's Edit mode but the Save Button remains greyed-out not allowing me to save changes.

This workflow is basic for App maintenance, users in GROUP1 need to be able to edit each other’s apps.

This is confirmed an issue on ArcGIS Portal 10.4.1

Can anyone confirm this issue also happens on portal 10.5.1?

0 Kudos
LemaoWu
Esri Contributor

"Even when the app is shared with a Group (created with the option to allow members to updated all content)"

It's a known issue on Portal 10.4.1 and has been addressed in 10.5 and later.