Refreshed WAB DE 2.7?

549
6
02-11-2018 10:06 PM
TimHayes
Regular Contributor

I have installed WAB DE 2.7. I have had WAB DE 2.2 and 2.4 up and running for quite some time no problems. 

But, when I install 2.7, it gets to "Repository Items Refreshed" and then the app fails to go any further. 

It started with no problems right after install. But, after I closed it, and re-opened, it does the refresh thing. 

Refer to the screenshot for what I am seeing:

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Tim,

   Is that a fresh install of WAB (with no apps currently) or did you use the upgrade command line to upgrade from a previous version?

0 Kudos
TimHayes
Regular Contributor

I have 2.4 running in a separate folder. 

I also got the same result with a fresh install on a totally different PC. 

I can run 2.4 and 2.5 no problem. Have never tried 2.6.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Tim,

   Have you tried deleting the whole 2.7 folder and re-downloading it again?

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I get the same thing

I then close that window and double click the startup.bat again and it will open the window and it will then start up properly.

I've had to do that process with all versions since I to not have the nodejs installed and running as a service all the time.  Best I can figure is the first time it starts up the service.  Closing and using the startup.bat again then works because it is now running.

AshleyCunningham
New Contributor

This happened to the second machine on which I attempted to install WAB, only it never made an initial successful launch. After downloading a fresh copy of 2.7, got the second machine to work only to have first machine "refreshing" again. With Node.js still running, I browsed to http://[yourmachinename]:[port]/webappbuilder and WAB started right up. Both clients are now up and running!

TimHayes
Regular Contributor

Thanks for the replies. I still cannot get it to work. So, I have installed WAB DE 2.6. It works good. I will wait until 2.8 comes out. Skip 2.7. Hopefully, 2.8 will not have the same problem as 2.7.

0 Kudos