Query widget buffer distance is inaccurate

1496
5
Jump to solution
07-22-2016 12:18 PM
ScottKiley
Occasional Contributor II

The Web AppBuilder Query widget's buffer distance is inaccurate for me. The distance is about 36.5% too short. For example when I enter a distance of 300' and then measure the buffer, it's actually only about 220'. The "Near Me" and "Situational Awareness" widgets both create accurate buffers when configured for the same app, so I'm guessing it's something with the query widget. Is there something in the Query widget configuration I'm missing that can help me with this?

0 Kudos
1 Solution

Accepted Solutions
QunSun
by
New Contributor III

Scott,

This bug is fixed on ArcGIS Online version.

WAB developer edition 2.2 will be released in weeks.

View solution in original post

5 Replies
ScottKiley
Occasional Contributor II

This image shows a buffer that should be 1,320' but only measures about 951'.

WAB_Query_Widget_BufferInnaccuracy.PNG

Here is a link to the app:

http://citywd.maps.arcgis.com/apps/webappviewer/index.html?id=72c1321a9a7045e7abc80e2d6c46b075

0 Kudos
QunSun
by
New Contributor III

Hi Scott,

It is a bug of Query. We will fix it in next release.

ScottKiley
Occasional Contributor II

Thanks Qun Sun​! Do you have an idea when that release will occur?

0 Kudos
QunSun
by
New Contributor III

Scott,

This bug is fixed on ArcGIS Online version.

WAB developer edition 2.2 will be released in weeks.

View solution in original post

DerekLaw
Community Moderator

Hi Scott,

FYI, Web AppBuilder for ArcGIS Developer Edition v2.2 is now available,

https://blogs.esri.com/esri/arcgis/2016/10/12/web-appbuilder-for-arcgis-v2-2-developer-edition-now-a...

Hope this helps,

0 Kudos