Problems with Edit Widget autofilling previously entered data

250
0
04-16-2020 12:03 PM
BillyHopper
New Contributor III

Is anyone else experiencing a problem with the Edit widget when trying to add new records to a related table from within WebApp Builder?

I have replicated this issue in both Hosted Feature Layers as well as Layers connected to a SQL database.

So what happens is, the user will go through the Edit Widget to add a record into a related table and when they add the first record, they can enter information into each field and hit save without issue.  When they go back to add a second record in, the form comes up like normal, but after they type information into the first field and tab to the second field, all of a sudden the information they entered into the previous record is populated into all of the fields.  

I have confirmed it is not related to auto-fill in the browser, and have tried IE11, Chrome, and Edge and they all reproduce this issue.

To make it even more strange, when the information is re-populated, the user clicks "save" but it does not actually send that information into the database twice, it sends what they typed into the first field and blanks out the remaining fields.  

Sorry if this sounds confusing and does not make sense, but it really feels like a bug with the Edit Widget and I am hoping to see what others have experienced in this regard.  Our portal is currently version 10.6.1 if that helps.

Attached is a .pdf relating to the original web app in our environment where I ran into this issue.  I have replicated it in several other web apps within our environment as well.

0 Replies