Printing Secured Services not successful

198
2
01-25-2019 02:37 PM
Sunita_Khanal
New Contributor II

There are so many posts related to printing secured services and I tried to follow the suggestions in those posts but no matter how hard I tried, I was not able to print my secured service. 

My scenario is, I have developed an application which is deployed in our server. Proxy has been set up, which is working fine in displaying secured services. I then created a custom print service by embedding user credential to it and saved it in a separate folder (not in default utilities). Both the folder and custom print service are not secured. Like other services, I added the custom print service in the proxy.config file. I also tried without adding the print service url and password but got the same error message as below. 

<serverUrl url="https://mydomain/arcgis/rest/services/CustomPrintingWAB/CustomPrintWebAppBuilder/GPServer/"
           username=" "
           password=" "
           matchAll="true" />

In the config.json file of my app, I added the rule as below. I was not able to load my app without adding rules for other secured services.

When I print, I get the following error message. 

Can anybody please point out what am I missing here. Also, please suggest creating a separate proxy folder is the preferred option. 

Thanks,

Sunita

0 Kudos
2 Replies
TanuHoque
Esri Regular Contributor

Hi Sunita,

I'd appreciate if you contact our Tech Support and have them take a look at this. It could be very hard to help you out on this issue without doing some investigation first.

Pls reach out to them, have them reproduce your bug in-house and we will go from there.

Thanks.

Tanu

0 Kudos
Sunita_Khanal
New Contributor II

Hi Tanu, 

Thanks so much for your suggestion. I will try one more time and would contact the tech support team if the issue still continues. 

-Sunita

0 Kudos