Migration Migraine

5581
8
Jump to solution
12-19-2014 09:56 AM
DouglasGennetten
New Contributor III

After overcoming the slight disbelief that one still has to download firefox to read the (largely unchanged) help files, I've proceeded an attempt to launch 1.0. I'm stuck at "Provide App ID for Web App Builder" where you have to "manually register the Web AppBuilder in you portal [sic]".

In the "Tip" section, I'm told the vital piece of missing information:  "During Web AppBuilder registration, you may input   http://[yourmachinename]:3344/webappbuilder as URL  of the app item."  I do this, and the page comes back unchanged with the exception of a new red border around the App ID input box. No errors. No helpful messages.  What am I missing?

1 Solution

Accepted Solutions
JakeSkinner
Esri Esteemed Contributor

Hi Douglas,

You need to register the Web AppBuilder with ArcGIS Online.  Log in to ArcGIS.com and click Add Item > An Application.  Specify http://[yourmachinename]:3344/webappbuilder as the URL:

screen1.png

After this, you will want to register the app.  See the section here under Register an App.  For the redirect URLs, you will want to specify your server name for HTTP and HTTPS.  Ex:

http://webserver

https://webserver

View solution in original post

8 Replies
JakeSkinner
Esri Esteemed Contributor

Hi Douglas,

You need to register the Web AppBuilder with ArcGIS Online.  Log in to ArcGIS.com and click Add Item > An Application.  Specify http://[yourmachinename]:3344/webappbuilder as the URL:

screen1.png

After this, you will want to register the app.  See the section here under Register an App.  For the redirect URLs, you will want to specify your server name for HTTP and HTTPS.  Ex:

http://webserver

https://webserver

View solution in original post

RobertScheitlin__GISP
MVP Esteemed Contributor

Sorry Jake you beat me to it.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Douglas,

one still has to download firefox to read the (largely unchanged) help files

Hmm... Not sure why you would think this. Firefox?..

You can browse with any browser you choose. Here is the online site with help, API reference and more Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

Adding the AppId part is a little confusing.

So when you go to your organizational account to you have a "Web AppBuilder for ArcGIS" entry?

If you do then you can just grab that AppId. Just click on the "Web AppBuilder for ArcGIS" item and then on the page that open find the "App Registration" section and "REGISTED INFO" link and click it and just copy that AppId.

If not then here are the steps

  1. Go to your Orgs My Content tab.
  2. Click Add Item > An Application.
  3. URL: http://[yourmachinename]:3344/webappbuilder.
  4. Type: Web Mapping
  5. Purpose: Configurable
  6. API: Other
  7. Title: Web AppBuilder for ArcGIS
  8. Tags: Registered App for OAuth
  9. OK
  10. Click REGISTER
  11. Leave App Type Browser.
  12. Enter: http://[yourmachinename]
  13. Click Add
  14. Enter: https://[yourmachinename]
  15. Click Add
  16. Click Register
  17. Copy AddId and enter it in your WAB Dev edition.
DouglasGennetten
New Contributor III

The installed help (/docs) still requires Firefox.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

I have launched the help from Firefox, Chrome and IE 11 and it works in all three browsers...

0 Kudos
BrianF_
New Contributor

I have tried on my own machine and it only works on Firefox for me as well.

My versions are:

Firefox: 34.0.5

Chrome: Version 39.0.2171.95

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

I am using Firefox 34.0 and Chrome

Version 39.0.2171.95 m.

What URL are you using? If you are using machinename:3344 then do you have JS Node command window open?

0 Kudos
AnthonyGiles
Frequent Contributor II

Douglas,

You can also register an existing web application if you have any in your organization, and use the app Id from that.

regards

Anthony

0 Kudos