Measurement widget in 2.5 showing segment lengths on Mouse Movement

308
6
Jump to solution
11-13-2017 08:12 AM
RichWestfall1
New Contributor

Hello, 

I am using the measurement widget in WAB2.5 and wanted to still have the distances and lengths show on movement of the mouse (or LAT/LONG).  Currently only clicking on the map will show length.  In previous versions of WAB a counter would show the distance as the mouse moved. I am not seeing a setting to change this on the widget itself.  Basemap is in State Plane as it was previously.  Does anyone know how to get this functionality in WAB 2.5.Thanks for the help!  

0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

OK,  So it looks way back at version 1.2 it worked the way you want it to work. It must have been something that changed from JS API 3.13 to 3.21 then.

View solution in original post

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Rich,

   I just tested WAB 2.4 using a web map that had a State Plane basemap and the measurement widget is acting the same (only updating when clicked). I am not sure what you were seeing before.

0 Kudos
RichWestfall1
New Contributor

Robert,

Thank you for your reply.  What I was seeing before is similar to your current elevation widget and site (but in State Plane).  I would select my first point on the map and as I moved the mouse the distance or lat/long would be displayed, counting up or down for length as the mouse moved.  Now I need to select two points on the map for the distance to be shown/returned.  

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Understood, I am just saying that it has always been that way (that I am aware of) when working with non-webmercator/WGS84 web maps.

0 Kudos
RichWestfall1
New Contributor

I agree, in recent iteration I am seeing the two click to return distance.  Users asked about this and I explained that that data was in state plane and this wasn't an option........then they reminded me of my old site, which I have back up, where it worked.  http://gisweb.cityofsantacruz.com/publicGIS 

I don't remember doing anything special here, but it was 3 years ago.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

OK,  So it looks way back at version 1.2 it worked the way you want it to work. It must have been something that changed from JS API 3.13 to 3.21 then.

0 Kudos
RichWestfall1
New Contributor

Thank you Robert for your help.  Apparently it is a bug at 3.14.

BUG-000092114: The cursor coordinates display section of the Measur.. 

0 Kudos