Incident widget wrong distance in WAB 1.2

01-28-2016 02:19 PM
by Anonymous User
Not applicable

I have WAB 1.2.   I decided to verify distances of all measurement tools in my site with known distances of parcel segments in our parcel dataset. (which is from a GA St Plane Ft SDE dataset)

This is using Chrome version 47.0.2526.111 m (64-bit)

Also observed in MS Edge.

Tom Sellsted's Measurement widget: correct.

Jeremie's eDraw: Correct.

Incident widget:  measurement errors.

Bug #1: 

It under-measures distances by approximately 10%. In WAB 1.2 of the widget. 1.3 measures correctly.

Error in measurement 1.2 is shown below. It should be 80 feet along the segment but it only drew a circle about 70 feet in length.

FINAL UPDATE:  ESRI's final answer for this is to upgrade to 1.3.  If you have WAB 1.2 do NOT use Incident Analysis, it's inaccurate as above/below. If anyone fixes it on their own at 1.2 let me know. I tried using the 1.3 vers of the widget in Builder 1.2, it didn't work. It 404d on CVUtils in jimu.js so I grabbed that, but after that, the errors became more complex in the console and I had to move on.

Actually....turns out, I'm going to permanently remove this widget. I just realized Robert's wonderful eSearch widget comes to the rescue again!  It can be used to simply draw a graphic buffer, if you select a 'dummy' layer that will produce no results.  The buffer graphic stays on the screen. I have 'dummy' layers as separators in my layer list and this workflow works perfectly.  Awesome!

Bug #2: (status: fixed! with a line of code below)

This is present in both 1.2 and 1.3.  It allows users to first type distance, then select point and click on the map. The problem is the graphic on the map is a different distance than the text that remains in the textbox inside the widget window.

The fix:  They created a click handler that makes the text below update and stay in sync with the slider so it looks like we have fixed it and it works in 1.3 and 1.2:    insert on Line 481     (insert under the following line....        this.own(on(this.horizontalSlider, "change", lang.hitch(this, this._sliderChange)));     )

  1. this.own(on(this.sliderValue, "change", lang.hitch(this, this._updateSliderValue)));

Note to ESRI Dev team, should be integrated into WAB1.4 and 2.0.

Background info:

We realized that reason where the number doesn't match the distance shown in the buffer on the map... was because I was first typing a number, and THEN clicking a Point.  As in, open the widget, first thing I do is type a distance, and then select a geometry type on the left panel for the buffer.  I stated that this should either be a user workflow that is allowed and works correctly, or it should NOT be possible.  Because the widget should not present one distance below and have a different distance on the map, ever. It is confusing and disconcerting for the user experience. The user should NOT be able to in other words get 'in trouble', either a feature should always work, or it shouldn't be there.

0 Kudos
0 Replies