How to Remove "Search More" from Query

208
4
02-22-2019 12:52 PM
AndyWells
Occasional Contributor II

I am using WAB 2.10, Developer. At some point the Query widget seems to be behaving different than in the past. I had a webmap at 2.8 with a query widget set up so that it would list all possible matches, like so:

But now, on version 2.10, it replaces the long list with a much shorter list of 6 items, followed by "search more" which you have to click to see the rest of the list results. How can I revert this back to the old behavior which was more intuitive? The new method appears like this:

I have seen this discussion https://community.esri.com/message/792992-how-do-i-get-my-query-widget-unique-values-back but that doesn't seem to get me very far. I appreciate any help you all may have.

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Andy,

   This is still strange to me. Here is what I am seeing in WAB Dev 2.11

I have yet to see the "Search more" 

What version of ArcGIS Server is your parcel layer coming from? Maybe that has some impact on this...

0 Kudos
AndyWells
Occasional Contributor II

The data is in ArcGIS Online, not ArcGIS Server. Here is a simple WAB map that is hosted in ArcGIS Online with two search queries, and both are limiting the search results until you hit "Search More". For example, if you do a parcel search for "Jones" which should return hundreds of matches, you get 4 entries then "Search More." But if you search for "Jon" you get 9 matches.. With "Jo" you get 78 entries, then "Search More." 

Here is the sample map. It is hosted on ArcGIS Online:

ArcGIS Web Application 

For comparison, this map uses the exact same parcel layer that is searchable in the previous link, but on this WAB map, it does not use the "Search More". The difference is, this is an externally hosted WAB 2.8 map.

ArcGIS Web Application 

It seems to me to be connected to changes to the query widget in some WAB release after 2.8. I've found some mentions of this here and there online, but nothing has helped. I've see this post already. Again, it is doing this for me with WAB 2.10 webmaps hosted externally as well as WAB maps hosted on ArcGIS Online at whatever release it is on. Both using feature layers hosted on ArcGIS Online.

The "Search More" button completely negates the excellent feature of your search being able to auto-complete as you type!


Thanks for your time.

0 Kudos
AndyWells
Occasional Contributor II

Just wondering if anybody else had any ideas. It seems to be an issue with WAB Developer Edition 2.9. 2.8 does not seem to do this.

0 Kudos
JadeWeideman
New Contributor II

Hi, we have seen the same behavior when using large datasets (WAB 2.13). It sometimes only shows "Search more" without showing any initial results and you have to click it to get your result, even if there's just one. See the screenshots below: 

In the above screenshots, the street name Zukova Cl is searched by entering the first 4 letters (should only show one result), but the user has to click on "Search more" before that result is returned.  

The above screenshot shows the parameter that might be responsible for this behavior.

The last screenshot just shows another example of the behavior, normally with more general searches.

 

Kind regards,

Jade

0 Kudos