How to install 2 versions of WAB Dev in the same machine?

685
5
02-08-2021 06:21 AM
Labels (2)
GerardMartin
Occasional Contributor

I have installed and running WebAppBuilder (Dev version 2.13) form several months, which is linked to ArcGIS Online account. Now, I have developed new App with WAB in Portal for Enterprise and I would like to customize some widgets.

So, I have downloaded a new version of WAB (Developers ver 2.19) that I have installed in another local disk in the same computer as WAB v2.13. I have registered an App inside Portal for Enterprise, but when I set App ID I get this error:

 

ArcGIS Portal Directory | 
Error

Invalid redirect_uri

Error: 400

 

I have checked several times this process, always deleting F:\arcgis-web-appbuilder-2.19\ArcGISWebAppBuilder\server\signininfo.json file, but authentication process always gives the same error.

Also, I have check that there isn't any running instance from previous WAB dev v2.13.

I have to say that I am using the same port 3344 but it is assigned automatically, and I have been using one instance of WAB a time

Is possible to have two versions of WAB in the same local machine? (only running once a time). How?

0 Kudos
5 Replies
KenBuja
MVP Honored Contributor

Yes, I've had multiple versions running. I kept each installation in a separate directory, with their own startup.bat file. I was using the same appId for the different versions.

GerardMartin
Occasional Contributor

@KenBuja Thanks for your answer !

I have WAB versions (2.13, 2.19) installed in separate directories, everyone with their startup.bat file:

  • C:\Users\username\Downloads\arcgis-web-appbuilder-2.13\WebAppBuilderForArcGIS\startup.bat
  • F:\arcgis-web-appbuilder-2.19\WebAppBuilderForArcGIS\startup.bat

In my case, v2.13 is linked to ArcGIS Online Account, and v2.19 is linked to Portal for Enterprise Account, so I think that in this case it is not possible to use the same appId for both versions of WAB.

Have you use the same port number? I don't think that the port number could be the reason of the error (because I am running ONLY ONE instance a time of node.js) but I can not find where is the problem ...

 

 

0 Kudos
KenBuja
MVP Honored Contributor

All of my instances were using AGOL, which is why I was able to use the same appId.

0 Kudos
LefterisKoumis
Regular Contributor

Install each version in their own directory. WAB is running on nodes.js. So, when you start WAB by double licking on the startup file, you start the node.js. I believe you cannot run two version of WAB at the same time (two node.js). If you want to run a different version of WAB, just close the start up file (by closing its command window) and start the startup file of the other version. Hope it helps.

GerardMartin
Occasional Contributor

Thank you @LefterisKoumis!  Yes, I am running only ONE node.js.

I can not see where is the problem with this installation ...

Thank you for your time.

0 Kudos