How do I remove commas from web app filter for year?

594
7
08-30-2017 01:21 PM
DanielleGuthrie1
New Contributor

I have a web app built in the "Web App Builder". A layer in this app has a year column and the years show up with a comma in the filter. Commas have been turned off for the map popup. Any ideas on how to remove the comma?

0 Kudos
7 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Danielle,

   Can you provide a snapshot of what you are talking about? I am just not following.

0 Kudos
DanielleGuthrie1
New Contributor

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Danielle,

   That is not currently possible. You will need to file an enhancement request with esri tech support. If you are using WAB Developer edition then I could look for the appropriate code to change for you though. Just let me know.

0 Kudos
DanielleGuthrie1
New Contributor

Thank you! That is all I needed to know.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Great, Don't forget to mark this question as answered by clicking on the "Correct Answer" link on the reply that answered your question.

0 Kudos
DanielleGuthrie1
New Contributor

 The year in the filter has a comma. How do I format the dropdown to not use a comma?

0 Kudos
KellyWright
New Contributor III

FYI, this is an ongoing issue in WAB within multiple widgets. Also see: Solution for BUG-000086319. There is still no solution to this problem. I have seen this in the Query, Filter, and Search widgets, and I believe I also saw the same issue in the Screening Tool, wherein fields selected for display on the report also show commas for numeric fields despite having commas turned off in the web map. In the Search widget, regardless of whether or not a field has commas turned off, the search returns display with commas. I did discuss this with developers at the 2017 DevSummit in Palm Springs, but no solution has been forthcoming since. 

0 Kudos