Header Controller Height

3813
11
Jump to solution
05-28-2015 08:06 PM
JeffWard
Regular Contributor II

Hey AppBuilders,

Where can I change the default height of the header controller in the stemapp?  I've changed the height property in the HeaderController\Widget.js file and that isn't changing the height of the header controller for new apps.  Is something overriding that setting?  I have looked everywhere and I can't seem to locate it.

Any help is appreciated.

Thanks,

Jeff

Jeff Ward
Summit County, Utah
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   OK, I found it. It is the predeined-apps.

[install directory]\client\stemapp\predefined-apps\default\config.json

make the same change as you did in the main config.json.

View solution in original post

11 Replies
JeffWard
Regular Contributor II

I have also modified the height property in the stemapp\config.json file, but new apps still have the default height of 40.  If I look in the new app's newapp\config.json file the height property is set back to 40.  If I change this value and launch the app it makes the changes in the app.

Does anyone know where this is getting overridden?

Jeff Ward
Summit County, Utah
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   The HeaderController Widget is part of the folding theme and thus you would have to modify the header controller widget in the stemapps foldable theme.

[install directory]\client\stemapp\themes\FoldableTheme\widgets\HeaderController\wigets.js

JeffWard
Regular Contributor II

Thanks for the reply Robert-

I have modified that height setting, and I have modified it in the [install directory]\client\stemapp\config.json file, but the new apps are still coming in with the default of 40 height.  When I open the new app's config.json in its root directory the height property is back to 40.  I would like to have all new apps have a wider header controller but can't find where it is being overridden.

Thanks,

Jeff

Jeff Ward
Summit County, Utah
0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   Did you notice the full path I provided above. If you modify it there then all new apps should maintain that height set.

0 Kudos
JeffWard
Regular Contributor II

Yes, I have modified that file.  And I agree, all new apps should maintain that height, but they aren't (for me at least).

HeaderController.jpg

The same file in the new app actually maintains this height setting, but the header controller stays 40px.

I also found [installation folder]\client\stemapp\config.json that has a height setting for the header controller in the widget collection.  If I change that setting to 80 and create a new app and open [install folder]\server\apps\[app number]\config.json it is back to 40.  But if I change it to 80 in that file after the app is created and launch the app again it actually changes.  It is either getting overridden somewhere else during the creation of the new app, or never comes across.

Could it be hard-coded into the building code?

Jeff Ward
Summit County, Utah
0 Kudos
TimWitt2
MVP Regular Contributor

Jeff,

Did you close out everything and restarted it? I noticed that some changes don;t take effect until I do that.

Tim

JeffWard
Regular Contributor II

I did try that, and just tried it again as well as clearing the browser cache, no change.  I even restarted my desktop.

Sometimes when starting up node.js it displays ....Repostiroy items refreshed..... and never brings up a web browser.  Is this normal behavior?  I usually close it down and start it up again and then it brings up the browser.  I'm using the startup.bat file to launch node.js not knowing any other way to do it.

Jeff Ward
Summit County, Utah
RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   Using the startup.bat is the correct way and I can confirm as you have seen that the bat does not always bring up the browser window. but all you have to do in that case is type the url (i.e. for me it is "http://gislap183:3344/webappbuilder/").

I will look into why the headercontroller height is not maintained in new apps and reply back.

RobertScheitlin__GISP
MVP Esteemed Contributor

Jeff,

   OK, I found it. It is the predeined-apps.

[install directory]\client\stemapp\predefined-apps\default\config.json

make the same change as you did in the main config.json.