Group Filter Widget Not Working

1271
2
07-25-2017 04:33 PM
RussellTess
New Contributor II

I am not sure if there is a limit to the number of layers that you can use a group filter on. In my current configuration of the widget I have about 45 layers that I am trying to filter on. They all have a common field in them. When I try to run the filter, arcgis online sort of freezes and the filter never runs. When I zoom in on the layers after running the filter, they do not redraw and just remain stuck/frozen. If I reconfigure the widget to only filter on about 15 layers at a time, then it works, although a bit slowly.

0 Kudos
2 Replies
Shingo-Ikeda
New Contributor III

I also have similar issue with this widget. I have only 5 layers and it filters attributes very well; however, the map layers stop refresh soon as I filter.  I am also seeing the widget not releasing its filter when the widget is closed with filter option (Persist after widget is closed) is turned off.

Shingo Ikeda
Geospatial Data Scientist/Developer - Geographical Information Platform
Global Power Generation - Digital Satellite USA and Canada
0 Kudos
EvaJuhasz
New Contributor III

I also have similar  issue with Group Filter widget, whatever number of layers I have. It does not work at all if I try to filter with a date field . If I use text or numeric filed, than it filters only the attributes, but does not the maps. version: ArcGIS Portal 10.5.  Does anyone in ESRI know about this bug?   

(ps. with ArcGIS Onlines WebApp Builder it seems to be working well, except  filtering with a date field.)

web app bulider‌  #widget group filter

0 Kudos