Geoprocessing widget issues

727
3
01-07-2021 01:48 AM
ahmadhasan3
New Contributor II

i created geoprocessing service using model builder and custom python script, when i added the published geoprocessing service to ArcGIS web builder its working fine, and its producing two output, csv file and feature class, now when i trying to add the output feature class to ArcGIS Portal content i received error saying Unexpected token '<' , i also checked the logs for arcgis server and arcgis portal and there was no logs for this issue, i tried also to export the result to feature collection and added as item to arcgis portal and again i am facing another error saying GeoJson doesn't  have 'type', then i tried to export the result as geojson and add it as item to arcgis portal and it works, so my question why i cant add the output to the portal content and what this error mean Unexpected token '<'

0 Kudos
3 Replies
shaylavi
Esri Contributor

Based on my experience and what you've shown, it might be that the json file is too large to be processed. Test it with a small string first to understand if it works at.

Shay
0 Kudos
ahmadhasan3
New Contributor II

so why when i export it from geoprocessing widget as Geojson it works fine and when i export it as feature collection it doesn't work ?

my concern now is how i can add the output to arcgis portal content 

 

0 Kudos
shaylavi
Esri Contributor

My answer was a "quick-fire" with no real understanding of the workflow or context to your problem - just to give you a possible direction to come-up with a solution. I don't have enough understanding to any of the workflows you have to make sense of this, sorry.

 

Shay
0 Kudos