Geoprocessing tool not functioning properly with Web AppBuilder

08-18-2016 12:38 PM
New Contributor

Hey All,

I am running into a couple issues while trying to publish a geoprocessing service and access it through the Web AppBuilder geoprocessing widget. The tool takes point features, buffers each point, and determines areas of overlapping buffers and areas where the buffers do not cover any of the region (in the case, the state of Alaska). The output is a layer with three polygons: areas with no buffer coverage (No Coverage), areas with less than three point buffers overlapping (Inadequate Coverage), and areas with three or more buffers overlapping (Adequate Coverage). The tool works in ArcMap 10.3 and, when published as a geoprocessing service and added as a toolbox into ArcMap, also generates the intended polygons. The primary issue:

I set this service as the Task URL for the geoprocessing tool widget in Web AppBuilder, and it appears in the configure window as it should. However, when I run the widget, it completes the task but only generates one of the polygons for the output layer. The tool is publicly shared on AGOL and can be found by searching for 'CORS', if that helps. It is unclear to me why the published service only produces this result when accessed through Web AppBuilder.

The secondary issue:

The No Coverage polygon is the area in the state of Alaska that is not overlapped by buffer coverage. In the tool, I use the 'Calculate Field' to replace the empty Coverage fields with "No Coverage" (the other coverage areas already have their appropriate Adequate or Inadequate Coverage fields populated). The python code block I use for this is:

def output(Coverage):
    if (Coverage == ""):
        Coverage = "No Coverage"
        return Coverage
        return Coverage

This works when I run the tool in ArcMap 10.3 but as a published service this appears to not happen. The No Coverage polygon fields remain blank. This happens both as a published service added as a toolbox in ArcMap and when running the geoprocessing widget.

Does anyone have any experience with issues similar to these?



0 Kudos
0 Replies