Filtering attributes does not work for related table layer in Web AppBuilder.

2047
4
09-01-2016 01:56 AM
Ermias_BeyeneTesfamariam
New Contributor

Hi,

 

I am trying to use the filter functionality of the Attribute Table Widget to display and export records of a related table layer (non geographic), but it is not filtering the records in the attribute table or the exported CSV.

It works perfectly fine with feature layers, so I am guessing it is a bug in the Web AppBuilder. I have attaced a screenshot of Chrome console logs, it says "Uncaught TypeError: Cannot read property 'setFilter' of null"

Ermias

4 Replies
RyanNosek
Occasional Contributor II

I actually think this is "expected behavior", which is to say, its probably not possible at this time. Might think of requesting an enhancement through the https://community.esri.com/community/arcgis-ideas?sr=search&searchId=bda5ca95-b923-4b5e-8104-6e4d1d0... site - there might already be one submitted for this, in which case vote it up so Esri can see that we need more support for working with Related Tables in across their web platform!  

BradJeffares
New Contributor II

I wouldn't think this is expected behavior otherwise why would they show the Filter button under the attribute table for related records. 

RyanNosek
Occasional Contributor II

I agree the functionality should be there, it probably should not be expected behavior since the controls are present to the end user. 

Aside from submitting a bug to Esri and/or requesting this functionality in ArcGIS Ideas, a possible work around for the OP would be to use WAB's Filter and/or Query Widgets with the non-spatial table data. Results generated using these widgets can be exported to CSV, and the output CSV will honor the parameters that were set in the query. 

0 Kudos
deleted-user-jxpbpbjlZInj
Occasional Contributor