Export Web Map Task: Failed to Create layer from service (print widget tool)

12-08-2021 06:50 AM
New Contributor III

I am using the standard web app builder template, with the standard print widget. I don't use any developer tools.

Link to my web app: https://wahkiakum.maps.arcgis.com/apps/webappviewer/index.html?id=cdb4fce60d854694b10f7cff69d557db

 I added Hexagon Imagery Service to web app builder using the add data,URL, WMS, token tool. I shared the layer with everyone. The imagery is working great, I have it turned on by default when the web app loads. It is at the bottom of my layer list and is called 2020 Hexagon Imagery.

Problem: Recently, when trying to use the print widget with the imagery turned on the print widget shows this error:



Error executing tool. Export Web map Task: Failed to create layer from service at https://services.hxgncontent.com/streaming/wms.

Failed to execute (Export Web Map).

Failed to execute (Export Web Map Task).



When I turn off the 2020 Hexagon Imagery layer and use the print widget it create the pdf without any issues.

Here is a screenshot of my printer widget settings, I haven't modified any of them:


This is the full service URL: 



Here are screenshots of the Hexagon layer information:








Could you help me figure out why the print widget has this error with the hexagon imagery and how to fix it?

Thank you!

0 Kudos
4 Replies
Esteemed Contributor

Does the server where ArcGIS Server is installed that is running the printing geoprocessing service have access to that image service URL?  My org has locked down internet access to servers, so certain URLs needed to be whitelisted for the AGS server so that all layers in web apps would print with the ESRI print widget.

0 Kudos
New Contributor III

I will ask my IT department and find out.

My imagery provider is also troubleshooting the issue and this is what he found out so far:

I’ve been doing some inspecting within your web map and it appears like the print function from WebMapBuilder is not sending thru the access_token during the print; thus it cannot fulfill the request.  I’m getting some headway searching for “arcgis online cannot print secure services”.  So we’ll see what I can find out!

Here is the JSON payload specifics on the Hexagon layer which were sent from the web map to the generic AGOL print services:



            "id": "wms_7506",

            "title": "2020 Hexagon Imagery",

            "opacity": 1,

            "minScale": 0,

            "maxScale": 0,

            "url": https://services.hxgncontent.com/streaming/wms,

            "type": "wms",

            "version": "1.1.1",

            "transparentBackground": true,

            "visibleLayers": [






There’s no Access Token parameter in there, so the print function can’t access that layer correctly. 

We need to find a way to append that access token thru to the print service – it appears like it can be done via ArcGIS Enterprise print utilities, but I haven’t found the documentation for ArcGIS Online – from most of the forums it seems like this was solved at some point in the past

0 Kudos
New Contributor II

Hi everyone,

Though this post is outdated, it might be worth mentioning that my solution to this was clearing the cache in the browser or using a different browser. It worked immediately after doing this.

Looks like Google Chrome was storing old metadata about the application in the background.

0 Kudos
New Contributor

Thank you for this feedback!  I just received this error and this helped me as well!

0 Kudos