[ERROR] repo - Manifest is bad.

2816
5
Jump to solution
02-04-2016 12:21 AM
GertConradie
New Contributor III

Hi

I get this error when WAB start up:

[ERROR] repo - Manifest is bad. D:\arcgis-web-appbuilder\arcgis-web-appbuilder-1.3\client\stemapp\widgets\ImageOverlay\manifest.json

I dont see anything wrong in the file contents. Any advice would be much appreciated.

WAB and the Widget runs/works as ecpected. The messase logged is just worrying.

{

  "name": "ImageOverlay",

  "2D": true,

  "3D": false,

  "platform": "HTML",

  "version": "1.3",

  "wabVersion": "1.3",

  "author": "abc",

  "description": "This is the custom widget",

  "copyright": "",

  "license": "http://www.apache.org/licenses/LICENSE-2.0",

  "properties": {

    "inPanel": false,

    "hasUIFile": false,

    "supportMultiInstance": false,

  "hasLocale": false,

  "hasStyle": false,

  "hasConfig": true,

  "hasSettingPage": false,

  "hasSettingUIFile": false,

  "hasSettingLocale": false,

  "hasSettingStyle": false,

  "IsController": false

  }

}

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Gert,

  The issue is that the strings.js that you copied from the ScaleBar widget is saying that there should be other language locale folders under the nls folder.

Open the strings.js file in the nls folder and delete these lines:

,
  "ar": 1,
  "cs": 1,
  "da": 1,
  "de": 1,
  "el": 1,
  "es": 1,
  "et": 1,
  "fi": 1,
  "fr": 1,
  "he": 1,
  "it": 1,
  "ja": 1,
  "ko": 1,
  "lt": 1,
  "lv": 1,
  "nb": 1,
  "nl": 1,
  "pl": 1,
  "pt-br": 1,
  "pt-pt": 1,
  "ro": 1,
  "ru": 1,
  "sv": 1,
  "th": 1,
  "tr": 1,
  "vi": 1,
  "zh-cn": 1,
  "zh-hk": 1,
  "zh-tw": 1

View solution in original post

5 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Gert,

   I have gone over it several time even checking the CaSe of each property and I can not find a issue... Can you zip your whole widget and attach it for me to test if I get the message on my side?

0 Kudos
GertConradie
New Contributor III

Hi Robert,

So that message are pointing me to the contents of the widget manifest file?

The copy in my 'stemapp' folder attached.

Much appreciated!

RobertScheitlin__GISP
MVP Esteemed Contributor

Gert,

  The issue is that the strings.js that you copied from the ScaleBar widget is saying that there should be other language locale folders under the nls folder.

Open the strings.js file in the nls folder and delete these lines:

,
  "ar": 1,
  "cs": 1,
  "da": 1,
  "de": 1,
  "el": 1,
  "es": 1,
  "et": 1,
  "fi": 1,
  "fr": 1,
  "he": 1,
  "it": 1,
  "ja": 1,
  "ko": 1,
  "lt": 1,
  "lv": 1,
  "nb": 1,
  "nl": 1,
  "pl": 1,
  "pt-br": 1,
  "pt-pt": 1,
  "ro": 1,
  "ru": 1,
  "sv": 1,
  "th": 1,
  "tr": 1,
  "vi": 1,
  "zh-cn": 1,
  "zh-hk": 1,
  "zh-tw": 1
GertConradie
New Contributor III

Thanks Robert, much appreciated!

..reminding myself to search a bit wider next time...

0 Kudos
PrabathRepaka
New Contributor

Thank Robert , that helped me

0 Kudos