Downloaded website from Web AppBuilder shows ERR_SSL_PROTOCOL_ERROR when started from Visual Studio

10-15-2020 10:32 AM
Occasional Contributor II

Hi! I created a GIS website from ArcGIS Web AppBuilder 2.17 running from my desktop computer. The site runs well if I start the Web AppBuilder from desktop, and then click to launch the website from there. However, if I download download the site from Web AppBuilder (with the download button beside the launch button), I cannot run it properly from Visual Studio 2019.

Can I get some idea about how to fix the ERR_SSL_PROTOCOL_ERROR error when I try to run it from Visual Studio?

I opened the unzipped downloaded folder from Visual Studio as a website, and clicked the run button. The popup web browser will display blue color that looks like loading the site for a second, and then display error message ERR_SSL_PROTOCOL_ERROR.

Attached are the screenshots of error messages I got when trying to start it from Visual Studio with different web browser.

Edge error

edge error

chrome error

IE error

Thank you!

0 Kudos
1 Reply
Occasional Contributor II

I also set SSL Enabled to true and tried, but still doesn't work.

enabled ssl in developer web server of Visual Studio

0 Kudos