Does symbology derived from an Arcade expression not display in the Smart Editor widget templates?

843
6
Jump to solution
06-26-2020 07:38 AM
AdamGebhart
Occasional Contributor III

Does the Smart Editor widget not inherit or display symbology derived from an Arcade expression in an AGOL map?

I have a WAB (Developer 2.13) app in which I'm using the Smart Editor to draw utility permit line features.  When I use my AGS feature service as its published, the symbology looks fine in the feature template section (see 'Utility Permits from Service' in first image below).  Said symbology is based on field called UtilityType. 

Since I published the service, the users want to only display line features where an additional Display field value = 'Yes'.  So, I've created an Arcade expression (provided at bottom) to only display each utility type when Display = Yes.  I then set the symbology in AGOL accordingly.  The problem is that symbology does NOT carry over to the feature template section in the Smart Editor widget (see 'Utility Permits').

For comparison, the symbology shows up just fine in the Layer List widget (second image).

Is this a limitation or is there something else I need to do? 

Screenshot of Smart Editor widget features templateLayer List widget displays symbology correctly

var utility = $feature["Utility_Type"]
var display = $feature.Display

if (display == 'Yes' && utility == 'Electric'){
    return "Electric"
}
else if (display == 'Yes' && utility == 'Gas'){
    return "Gas"
}
else if (display == 'Yes' && utility == 'Communication'){
    return "Communication  "
}
else if (display == 'Yes' && utility == 'Water'){
    return "Water"
}
else if (display == 'Yes' && utility == 'Drainage Tile'){
    return "Drainage Tile"
}
else {
    return "Not Displayed (No)"
}

0 Kudos
1 Solution

Accepted Solutions
AlixVezina
Esri Regular Contributor

The example above would also apply for a feature service with ArcGIS Server - unfortunately, the template picker in the Smart Editor widget doesn't display the symbology set in the web map using arcade.

View solution in original post

0 Kudos
6 Replies
AlixVezina
Esri Regular Contributor

Hi Adam Gebhart‌,

Thank you for sharing your question.

The Smart Editor widget is will display the templates as they were published with your service.

As a workaround, you may want to try updating the layer symbology from the Visualization pane in the layer's item detail.

  1. Go to the visualization tab
  2. Select the layer
  3. Update the symbology
  4. Save the Layer

5. Add  the layer with the updated symbology to your web map (add it again an remove the previous layer if it was already in your map)

6. Update the Smart Editor widget configuration and Save

7. Launch your app

Please note the Smart Editor widget does not currently support displaying symbology set using arcade.

Your use case will be taken into consideration for our future enhancements and we will let you know of any related updates.

Regards,

Alix

0 Kudos
AdamGebhart
Occasional Contributor III

Alix Vezina‌ - thank you for the reponse.  Just to clarify though, does your example refer to a hosted feature layer?  I am working with an ArcGIS Server feature service and not a layer hosted in AGOL or Portal. The web map consumed in a WAB 2.13 (Developer) app resides in AGOL.

0 Kudos
AdamGebhart
Occasional Contributor III

Replying to myself here, but posting another example of what I'm seeing in case anybody experiences this or knows of a work around.

In the first image below, the top section (Utility Permits) is the symbology from the feature service. The bottom section is that same data but published as another item/endpoint in the same service, but where every feature has the same symbology (see Utility Permits - Arcade symbology). 

Each endpoint is added to my AGOL web map individually.  In the Utility Permits section I did NOT add an Arcade expression.  In the second section I did add the Arcade expression displayed in my original post on 6/26.  The second image shows the symbology I see in AGOL based on that expression.

Any idea why the symbology via the Arcade expression won't show up in the templates?

Smart Editor Feature Template ScreenshotSymbology from Arcade expression

0 Kudos
AlixVezina
Esri Regular Contributor

The example above would also apply for a feature service with ArcGIS Server - unfortunately, the template picker in the Smart Editor widget doesn't display the symbology set in the web map using arcade.

0 Kudos
AdamGebhart
Occasional Contributor III

Thanks for the information.  It seems odd that the Layer List inherits the Arcade symbology, and perhaps other widgets (?), but not the Smart Editor.  Regardless, now I know how to proceed.  Thanks again.

JenniferOtter
New Contributor II

Hi Alix,  I have followed the directions (updated the symbology in visualization tab and deleted and then re-added the hosted layer to my map.  The Smart Editor App still refuses to show the newly added domain choice (though it is in the legend)

-Jen

0 Kudos