Directions Widget in My Trash Services app not allowing public access

09-10-2021 06:05 AM
Labels (1)
Occasional Contributor III

So I have been trying to configure the Directions widget in the ESRI My Trash Solution to allow public access.

I followed the instructions here

I also tried configuring Subscriber Content links in the attributes of the app.

It works fine if I'm accessing the app via AGOL - but when I download the code and try to deploy on my own server - it starts prompting for credentials if someone uses the Directions app.

I checked, and the config.json file is using the URL of the routing service I created following the above article. 

I think I'm missing a step somewhere.  This is my first self-hosted app that uses credit-consuming services.

Any tips?  Thanks in advance!

Link to the application


So I have found 4 methods for attempting this & am documenting here my results.



1. Add route URL to NearMe Widget / configure the subscription services in the WAB Attributes (DID NOT WORK)

2. AGOL - embed route URL & credentials in an item and use that URL in the NearMe Widget (DID NOT WORK)

3. Generate API Key using developer dashboard (SOME SUCCESS) 

Followed instructions here and replaced the routing service URL in the config.Json with the proxy URL from the dashboard and now... it still prompts for credentials, but you can see the route in the background and if you cancel the credential window, you can see and print directions.

How do I get rid of the credentials screen?  I'm new to proxies and all of this seems excessive for trying to download WAB solution and deploy it but I'm learning as I go!

4. Download a proxy (Haven't tried yet)


0 Kudos
3 Replies
Esri Esteemed Contributor

@Kara_Shindle here is the URL that the Directions widget is referencing:

It doesn't appear that this is shared with Everyone.  I would check this URL with the URL for the AGOL item (step 8 of the document).

0 Kudos
Occasional Contributor III

@JakeSkinner  that is the Routing item I created - I just checked the URL again - and it is set to be shared with everyone.  

0 Kudos
Occasional Contributor III

So I'm seeing a TypeError: in the developer tools that says "Cannot read properties of undefined (reading 'containerNode') and it's referencing the NearMe widget.  This was after I tried entering credentials when it prompted and it still failed.  Maybe I've not got the correct URL for the routing service in my item?

0 Kudos