Developer's Edition (can't switch to tabbed theme)

3608
6
03-04-2015 12:54 PM
BrianDudek
Occasional Contributor

I also installed the LocalLayer widget from github to go with it, and it all seems to function except when I try to switch to the tabbed view.  When I click that the whole side panel freezes and does nothing, while the map elements still function.    Is this because of the custom widget or something else gone wrong?    I am totally new to all of this, so thank you for the assistance.

0 Kudos
6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Brian,

   Did you follow the instructions on the GitHub readme.md on how to add the widget to the tabbed theme?

The default theme in WAB is the foldable theme so adding the Local Layer widget to the Tab theme involves another step.
0 Kudos
BrianDudek
Occasional Contributor

Yes sir.  Still trying to determine the issue.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Strange. I just tested and can switch to tab theme just fine with the local layer widget installed.

Actually there seems to be an issue when switching theme while the LocalLayer Widget is active.

If I turn the visibility of the LocalLayer widget off first then switch themes there seem to be no issue though.

BrianDudek
Occasional Contributor

Actually looks like Page 3 number 1 under Rebecca's PDF was messing it up.  This time I did not mess around with Layout1 at all and I fixed it.

https://community.esri.com/blogs/myAlaskaGIS/2015/02/04/tips-for-using-the-custom-locallayer-widget-...

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Brian,

   OK that explains it. Those instructions were from an older version and #1was found to cause an issue and thus removed from the readme that we now have on github.

0 Kudos
RebeccaStrauch__GISP
MVP Esteemed Contributor

I'll take a look at my pdf and get it updated ...or link to this thread until I can. sorry about the outdated instructions.

0 Kudos