Changing serviceURL for Print Widget

2630
4
10-30-2014 01:49 PM
by Anonymous User
Not applicable

In which files do I have to update the serviceURL for my app's Print widget? I updated it in config_Print.json, but my app is still recognizing the old print service I had registered. I want to change it back to the default AGOL print service: Task: Export Web Map Task

0 Kudos
4 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Ben,

  Which WAB are you using? The online, the Developer version? If you are using the developer version make sure you are changing the config_Print.json in the correct apps folder.

0 Kudos
by Anonymous User
Not applicable

Using WAB beta 3, developer version. I downloaded my app and am hosting it in a different folder other than the default arcgis-web-appbuilder-1.0beta3 developer folder.

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Ben,

     So are you saying that you changed the print service url in the print-config.json in that downloaded apps folder and that app is still using the old url?

0 Kudos
by Anonymous User
Not applicable

Yes. But it's working now for some reason. I don't understand why it wasn't instantaneous. It didn't work the first time because I was getting the error below, which I'm assuming meant the app was still recognizing the old service url blacked-out below. This error no longer pops-up so I take that it's using the default AGOL print service url that I set it to.

2014-10-30 10_41_19-ArcGIS Web Application.png

0 Kudos