Bing basemap seems to have affected my basemap widget

380
1
Jump to solution
06-28-2019 01:02 AM
JordanMiller2
New Contributor II

Hi all,

I recently trialed using Bing aerial imagery as a basemap. After a few days I decided to switch back to the basemap I was previously using, New Zealand Aerial Imagery (which is in New Zealand Transverse Mercator projection, NZTM).

While the NZ Imagery is displaying correctly as the basemap in my app, the basemap widget is now missing all the other New Zealand basemaps that were previously available. Oddly, this is ONLY occurring where I have webapp embedded in a webpage - when I open the app on its own, the correct basemaps are shown in the widget.

I've attached screenshots but it's just as easy to provide links to shows the issue:

Incorrect basemap widget options (in embedded app on bottom left): https://nelsontrails.co.nz/moa-park/

Correct basemap widget options: https://nt-nz.maps.arcgis.com/apps/webappviewer/index.html?id=876f42ecda624c5da78911e2817570c8

I've tried lots of things, including removing and re-adding the basemap widget, switching to other NZTM basemaps, removing the Bing key from my organisation... no luck so far. I'm really hoping I don't have to recreate my webmap to remove any lingering WGS84 effect that Bing may have had.

Any help would be appreciated!

Cheers

Jordan

0 Kudos
1 Solution

Accepted Solutions
JordanMiller2
New Contributor II

I've answered my own question - not sure if it's a 'quick fix' or the correction solution, but in the webapp basemap widget configuration, I switched from 'Always synchronize with the Basemap Gallery setting of the organization' to 'Configure custom basemaps', and then imported my Organisation default' options.

View solution in original post

0 Kudos
1 Reply
JordanMiller2
New Contributor II

I've answered my own question - not sure if it's a 'quick fix' or the correction solution, but in the webapp basemap widget configuration, I switched from 'Always synchronize with the Basemap Gallery setting of the organization' to 'Configure custom basemaps', and then imported my Organisation default' options.

View solution in original post

0 Kudos