Batch Attribute Editor issue

220
5
Jump to solution
01-04-2021 07:02 AM
BillHeigh
New Contributor III

Greetings fellow cartographers,

I am having in issue that I've been working on and can't find any answers to. It is with the WAB (not sure how to verify the version, I looked for the ol' Help/About but didn't see it). I've been working with both current FireFox and Chrome, but no joy.

Basically I can't save my configuration for the Batch Editor widget. It just tells me that I need to finish configuring before I can save.

SS_BatchEditor.PNG

I have tried changing every single option but to no avail. I have searched the world over and found no other instance of this happening. There are plenty of issues with this widget, but I seem to stranded here.

I saw a post about using the Smart Editor widget as a work around to a different issue and I tried substituting that, but testing that tool only resulted in an empty dialog asking me to choose a template for new features, which I have created. But apparently I'm missing something there too because there was nothing to choose from in the dialog box.

I really would like this Batch Editor to work however, because it seem like the correct widget for my intended task. The task is for our Safety Drive-By Inspections (aka the 7mph drive-by). We inspect about 3,000 power poles every year and about 150 pad-mount transformers. We only observe about 1% or less of our system that needs attention.

Our current workflow involves the inspector tagging certain poles as Start and Stop to indicate where he was at that time and place and then we subjectively fill in the blanks and count the poles from ArcMap, more or less manually. It works but it would be better if he were able to batch edit and we could then just download the results without subjectively counting them in ArcMap or Pro. Ultimately I would also like to build a dashboard with tiles for more folks to be able to see the progress. And one of the first things we report on are any records with attachments. Those get printed and passed around and misplaced, etc. so we sometimes have to re-create the prints.

Thanks in advance, Bill~

1 Solution

Accepted Solutions
AlixVezina
Esri Contributor

Hi @BillHeigh,

For this widget to work as expected, please make sure the layers you have selected in the "Define Layer(s) to Update" tab have common field names. Only common fields from the layers you've selected will be listed in the "Define Field(s) to Update". You can then select the fields you would like to batch update from there and save the configuration. The widget configuration cannot be saved if no layers were selected and no fields were selected. If you select only one layer to update, the fields should be listed as well.

Regards,

Alix

View solution in original post

5 Replies
AlixVezina
Esri Contributor

Hi @BillHeigh,

For this widget to work as expected, please make sure the layers you have selected in the "Define Layer(s) to Update" tab have common field names. Only common fields from the layers you've selected will be listed in the "Define Field(s) to Update". You can then select the fields you would like to batch update from there and save the configuration. The widget configuration cannot be saved if no layers were selected and no fields were selected. If you select only one layer to update, the fields should be listed as well.

Regards,

Alix

View solution in original post

BillHeigh
New Contributor III

Hi @AlixVezina,

OH!! Okay well I have only two Operational Layers and I wanted the ability to update either one, but I'll separating them out into two widgets.

Thank you so much for your prompt reply!

PeterGoedbloed1
New Contributor

Hi @AlixVezina I am running into the same issue. Although I want to ultimately have the Batch Attribute Widget to look at two layers (that share the same field though). I keep getting the 'No common fields' message even if I select just one layer. Should the field meet certain criteria to appear for selection? I have a text field with a domain that I want to use.

Reply
0 Kudos
PeterGoedbloed1
New Contributor

I just made a screencast to demonstrate the workflow: https://www.screencast.com/t/OT5JIqYK

Reply
0 Kudos
AlixVezina
Esri Contributor

@PeterGoedbloed1 Thank you for sharing the recording, that's very helpful!
The only thing I can think of is to verify in your web map to make sure the fields you would like to update are set to be editable in the pop-up configuration?

AlixVezina_0-1613579567091.png

 

Reply
0 Kudos