Basemap Gallery Issue

1131
4
03-31-2017 08:25 AM
JasonStanton__GISP
Occasional Contributor

Greetings,

In v2.4 - when i add the basemap gallery widget it is somehow also loading the thumbnail associated with the webmap at the end of the basemaps i have loaded.  Anyone else seeing this and/or have any thoughts on how to resolve it?

Any assistance would be greatly appreciated.

Jason

0 Kudos
4 Replies
RyanKelso
Occasional Contributor III

Jason Stanton, GISP‌, did you ever resolve this issue?  I have the same thing happening.  The widget's help says:  "If the basemap used in the web map is not included during the configuration, it will be added automatically when the widget opens."

My problem is, I have around a dozen basemaps configured in my widget, which includes the basemap used in the app's web map.  But the widget is adding a second copy of this same basemap to the end of the list.  Something is not working correctly.

0 Kudos
JasonStanton__GISP
Occasional Contributor

Ryan, The solution I found, working with Esri support (though they state that modifying code is not recommended) was to:

  • Navigate to <app location>\widgets\BasemapGallery\
  • Open Widget.js file
  • On line 140 change utils.compareSameBasemapByOrder to utils.CompareSameBasemap
  • This should remove the duplicate basemap in the widget

The URL for the basemaps has to be exactly the same (i.e. if your WebMap basemap URL is HTTP and the URL of the basemap in the config file is HTTPS, this solution will not work). 

KeithWitt
New Contributor III

I'm having the same problem in this thread, https://community.esri.com/thread/194906-what-do-my-web-apps-have-an-extra-streets-basemap My WebMap is consumed by an AGOL-hosted WebApp developed using WebAppBuilder so it doesn't appear that I have access to Widget.js. Something clearly happened with the WebAppBuilder code as my maps (1 & 2 years old) did not have this problem when they were created (2016 & 2015).

0 Kudos
JasonStanton__GISP
Occasional Contributor

Keith,

I’m not sure if there is a solution for your issue. Be sure that the URLS are exactly the same… if they are I would reach out to Esri- this can’t be the desired result.

Jason Stanton, GISP

GIS/IT Director, Montachusett Regional Planning Commission

1427R Water Street

Fitchburg, MA 01420

Phone: 978.345.7376 x313

Fax: 978.348.2490

Email: jstanton@mrpc.org<mailto:jstanton@mrpc.org>

This summer, the MRPC will move from its current location (1427R Water Street, Fitchburg, 01420) to its new home at the Doyle Center (464 Abbott Avenue, Leominster, 01453). The relocation of the office will take place on Saturday, June 24th and Monday, June 26th. Phone and email communications are anticipated to be fully operational through Friday, June 23rd. Our phone and email system is expected to be nonfunctioning on Monday the 26th, but be will be reconnected no later than Tuesday the 27th.

Please be advised that the Massachusetts Secretary of State considers e-mail to be a public record, and therefore subject to the Massachusetts Public Records Law, M.G.L. c. 66 § 10.

0 Kudos