ArcGIS Web appbuilder won't start

04-12-2021 09:19 PM
Labels (1)
New Contributor



I just downloaded the ArcGIS Web appbuilder developers edition. Tried installing it following the given guidelines. Unzipped as instructed double click on the startup, it runs but the web app builder does not start in any of my browsers.

The attached image above is what I get, waiting patiently to start but it not.

Please if anyone can assist me on this I will be glad.

Thank you.

Tags (1)
3 Replies
Occasional Contributor III

What comes up in the browser when you go to http://localhost:3344/webappbuilder/ ?

You should be prompted to bypass the certificate error and then get a screen prompting you to give it the key from Portal. My own notes on setting up the key are on this page: about halfway down under Setting the App Id from Portal

Output from mine looks like this, (running in Linux in a Docker container), in other words, the same as yours,

wabde_1 | Server listening tcp connection on port 3344 in development mode
wabde_1 | [2021-04-13T15:11:31.289] [INFO] repo - Read repository items: /srv/client/stemapp/widgets
wabde_1 | Server listening http connection on port 3345 in development mode
wabde_1 | Server listening https connection on port 3346 in development mode
wabde_1 | [2021-04-13T15:11:40.715] [INFO] repo - Read repository items: /srv/client/stemapp/themes
wabde_1 | [2021-04-13T15:11:43.364] [INFO] repo - Read repository items: /srv/client/stemapp3d/widgets
wabde_1 | [2021-04-13T15:11:45.651] [INFO] repo - Read repository items: /srv/client/stemapp3d/themes
wabde_1 | .............Repository items refreshed..............

Occasional Contributor III

Is it possible the firewall is blocking access on your machine?

0 Kudos
New Contributor

Hi Brian,

Yes, I was prompted by a firewall blocking my computer but I enabled it to allow it as the pop-up indicated.

Another thing a reliance and corrected was were the set up was stored on my computer (Desktop). I changed the location by copying it to my programme files and to my surprise it worked, ArcGIS Web appbuilder started running in my browser.

Thank you for your support kind support, Brian. I appreciate.