AppBuilder Invalid redirect_uri

29202
31
Jump to solution
01-14-2015 01:17 PM
SarahLinden
New Contributor II

This is my first time using web app builder. I got to the point where I registered my apps URL properly, but must have used the wrong App ID....... I can't seem to get back to where I re-enter the appropriate app ID and am instead taken to a page that is blank and just says invalid redirect_uri

Anyone experience the same issue? Help! What should I do???

Tags (1)
31 Replies
RebeccaStrauch__GISP
MVP Emeritus

That seems to be the consensus.  Glad it worked for you.  

0 Kudos
JC-220
by
New Contributor II

Using both http and https address did it for me. Thanks to you I still have a little bit of hair left.

0 Kudos
marcostenorio
New Contributor II

change the file serve/signininfo.json

img2.pngimg1.png

DavidWasserman
Occasional Contributor III

As Marcos said, you chang the App ID in signininfo.json or actually delete it and restart app builder.

It is explained on the FAQs here too: FAQs—Web AppBuilder for ArcGIS (Developer Edition) | ArcGIS for Developers

David Wasserman, AICP
0 Kudos
AaronKreag2
New Contributor II

I just spent 2 hours messing with this.  Everywhere that is says localhost I had to go through the process from scratch and use my fully qualified names like http://servername.domainname.local:3344/webappbuilder

I did this during the web app builder registration process on my AGO account and in the redirect URI screen with http and https.  This is not well documented at all.

JosiahCorona2
New Contributor II

I know this is a very late response but I had this issue this morning and I fixed it quite simply!

Go to your C:\..........\arcgis-web-appbuilder-2.0\WebAppBuilderForArcGIS\server

Then open your signinginfo.json file

there it gives you the option to change URL and App Id if need be.

Help.PNG

0 Kudos
GeoffreyWest
Occasional Contributor III

What is the solution for this for an app deployed on a local server? I have downloaded my application and configured it on IIS. When I register the app, what do the server:[port] refer to to redirect local URI?  Also what does the URL refer to? Is this the URL where the app is being accessed from?      I am receiving an Invalid URI error.    

0 Kudos
RebeccaStrauch__GISP
MVP Emeritus
0 Kudos
GeoffreyWest
Occasional Contributor III

Rebecca,

This isn't the Developer Edition.  I have downloaded the my app from AGOL but am receiving a URI error.

0 Kudos
gangatrial
New Contributor

Hi, I was struggling with this 'Invalid redirect_uri with error 400'. After 30 minutes of all try and error, did 2 things. of this, which one solved I am not sure. 1. Changed my default browser from IE  11 to Google Chrome v 49.0 2. While providing the redirect uri;s included domain name. ex: https://.:3344 and it Worked !

0 Kudos