App keeps loading in Chrome after deployment

1468
8
Jump to solution
08-29-2016 05:08 AM
BenedekSimó
New Contributor III

Our app is loading extremely slow after deployment from WebApp Builder  (Developer Edition) 2.1. Investigating the Console and Network tabs in Chrome did not help to solve the issue, nor looking at the logs of Server for ArcGIS and Portal for ArcGIS.  (In mozilla it works though...)

Could someone more experienced take a look what might happens?

https://map.mfgi.hu/fdt100/ 

Thank you in advanced!

Ben

Tags (1)
0 Kudos
1 Solution

Accepted Solutions
BenedekSimó
New Contributor III

Dear Robert,

I think you won't believe what was my problem...

After comparing the aformentioned working app's directory with the non working app's directory, it turned out that the problem is in the config file. It seems that if in mapOptions there is an "extent" object (likely generated when the user selects Use Current Map View for setting the initial extent) the app simply not working correctly. After deleting that section, everything works magically.

So it was not https, accented charachters, wrong layers but rather a tiny little config option. Hopefully it will be corrected for the next version. But anyways, thank you for your help, I really do appreciate it! :)

Cheers,

Ben

View solution in original post

8 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Benedek,

  I thought your issue was with the AT widget but I now see that it is set to visibility false. So that means that the issue is part of a big on going issue with Chrome 52 and HTTPs.

https://community.esri.com/thread/181102#comment-630264 

One thing you may try is setup and use a proxy with your app.

Setting up a Proxy | Support Services Blog 

Releases · Esri/resource-proxy · GitHub 

BenedekSimó
New Contributor III

Hello Robert,

Hopefully I have successfully implemented the proxy to my page, but it is still not loading correctly. The worst thing is that there is no error message as such, so I feel kinda lost. Interestingly though, we have another app that uses the same resources and it runs correctly: https://map.mfgi.hu/atlasz200/ 

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Benedek,

   After some tetsing it seems that you app is having an issue returning most of the widgets' json files.

https://map.mfgi.hu/fdt100/configs/MyLocation/config_SajĂĄt hely mutatĂĄsa.json

yet other with English names return fine:

https://map.mfgi.hu/fdt100/configs/Splash/config_Splash.json 

0 Kudos
BenedekSimó
New Contributor III

Hey Robert,

Thank you, I have changed the name of the json files as well as their URL in config.json, but it still struggles with something...

The only thing that I have changed with the source code is that the framework does not supports out-of-the box hungarian language, so I have changed init.js to set the dojoConfig.locale = 'hu', and then I have added the required folders and jsons. Is there anything that can be wrong with this?

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

Benedek,

    I would eliminate that possibility by removing the  dojoConfig.locale = 'hu',

BenedekSimó
New Contributor III

Still no success...

0 Kudos
RobertScheitlin__GISP
MVP Esteemed Contributor

The error I am seeing now is that this layer timed out:

https://map.mfgi.hu/arcgis/rest/services/fdt100/fdt_100/MapServer

Maybe remove that layer from the app for testing purposes

0 Kudos
BenedekSimó
New Contributor III

Dear Robert,

I think you won't believe what was my problem...

After comparing the aformentioned working app's directory with the non working app's directory, it turned out that the problem is in the config file. It seems that if in mapOptions there is an "extent" object (likely generated when the user selects Use Current Map View for setting the initial extent) the app simply not working correctly. After deleting that section, everything works magically.

So it was not https, accented charachters, wrong layers but rather a tiny little config option. Hopefully it will be corrected for the next version. But anyways, thank you for your help, I really do appreciate it! :)

Cheers,

Ben