Any timeline on moving Web AppBuilder to full Javascript API v4.x for 2D and 3D?

1121
6
Jump to solution
09-04-2017 08:00 PM
FrancescoTonini2
Occasional Contributor II

Does anyone know if there are plans (and timelines) for moving WAB into a full-fledge Javascript API 4.x for customizing both 2D and 3D web apps?

1 Solution

Accepted Solutions
RobertScheitlin__GISP
MVP Esteemed Contributor

Francesco,

   They do not plan to move until the 4.x is more mature and contains editing and drawing tools. I personally hope that they to not rush into the 4.x migration as there is still som many things missing from the 4.x API.

View solution in original post

6 Replies
RobertScheitlin__GISP
MVP Esteemed Contributor

Francesco,

   They do not plan to move until the 4.x is more mature and contains editing and drawing tools. I personally hope that they to not rush into the 4.x migration as there is still som many things missing from the 4.x API.

View solution in original post

FrancescoTonini2
Occasional Contributor II

Thanks for the info Robert!

0 Kudos
FrancescoTonini2
Occasional Contributor II

Robert, do you know how to check the Dojo version used by WAB 2.x? I am using WAB 2.5 right now but in general I want to make sure I am consulting the correct documentation for Dojo online. Thanks!

0 Kudos
KenBuja
MVP Honored Contributor

From the FAQ

The latest release of Web AppBuilder always synchronizes with the latest release of ArcGIS API for JavaScript. To get the latest version of ArcGIS API for Java Script that is supported by the latest release of Web AppBuilder, see Requirements and browser support.

For Web AppBuilder for ArcGIS 2.5 (Developer Edition), 2D apps support ArcGIS API for JavaScript 3.21, and 3D apps use ArcGIS API for JavaScript 4.4. JSAPI 3.21 uses Dojo 1.12.2

RobertScheitlin__GISP
MVP Esteemed Contributor

Francesco,

   WAB 2.5 is using JS API 3.21, so:

Dojo version 1.12.2 (since version 3.21)

NicolasGuilhaudin
New Contributor II

True, but it would be also nice to have 2 WebAppBuilder 3.x and 4.x both following the update of the API to prepare the transition as well .

0 Kudos