Select to view content in your preferred language

After AGOL updates, Web App Builder Geocoding Functionality broken.

5465
23
07-14-2015 06:18 AM
PaigeLester1
New Contributor III

My organization uses our own Composite Address Locator Geocoding Service that has been published to our own ArcGIS Server. Prior to ESRI's July updates to ArcGIS Online, with a Web App Builder Web App, when a street address is typed into the Search text box and the user pauses, the app returns a list of candidates from our Geocoding Service. After this 2015 July update, this behavior has changed without warning. After entering the address, one now has to press the enter key to return the list of candidates. The best candidates, e.g. the candidates with a match score of 100, are highlighted or bolded in black, but the highlighted best results are not selectable.

0 Kudos
23 Replies
WilliamRice
Occasional Contributor II

My screen snapshot below shows the "best" candidates returned from two different locators that are part of my published Composite Locator.  The "best" candidates are shown in bold in the list of candidates.  Yes, for these "best" candidates I have to click within the rectangular areas marked in red in the screen snapshot below.  i cannot click on the text which we have normally done in the past.

Will Rice

0 Kudos
Jianxia
Esri Regular Contributor

This has something to do with browser cache. After clean the cache, I was able to click on the text and zoom to the feature. It seems the bug fixed in 3.14 requires cache clean up.

Will, could you open the app in builder and save it again and see this helps?

Jianxia

WilliamRice
Occasional Contributor II

Jianxia,

I opened my Web App in Web App Builder in ArcGIS Online and then saved the app.  I then opened a separate browser, Internet Explorer, and cleared the client browser cache.  I then opened my Web App in IE.  For the Search Widget results,  I am still having to click on the area to the right of the text. 

With a Web App Builder app, how I can I tell what version of the JS API the app has downloaded to a client machine and is using?  I have tried viewing the source on a page but I don't see the references to the Esri arcgis javascript api libraries in the pages like index.html.

0 Kudos
WilliamRice
Occasional Contributor II

I just created a brand new Web App using Web App Builder (7/14/2015, 6:00 pm EST).  I am getting the same behavior with the Search Widget where I am having to click to the right of the text for the candidates that are highlighted with the bold font.

0 Kudos
Jianxia
Esri Regular Contributor

Will, IE takes some time to clear up the cache. Could you give it a try again? BTW which version of IE are you using?

0 Kudos
WilliamRice
Occasional Contributor II

Jianxia,

The issue is occurring with all the browsers that I use.  These browsers and their versions are: IE 11, Chrome 43, and Firefox 39.  I have been making sure that I clear the browser's cache before opening the web app.  I don't know of any other way to clear the browser's cache than what I am doing.

Here is a URL and link to our particular web app that was created previously with the Web App Builder:

IRC Address Viewer

Try this sample address with our Web App Builder web app:  1800 27TH ST

0 Kudos
Jianxia
Esri Regular Contributor

Thank you very much for all the info Will!

We took a look at your app in the console and found the Invalid URL error. This indicates that you may have a geocoder service older than 10.3 version. As mentioned by Robert, July update use Search widget to replace Geocoder widget. However Search widget in WAB supports Suggestion capability which requires 10.3 up geocoding service that has suggest capability loaded. Could you check the version of your geocoder, along with suggest capability if it is 10.3 up?

See the jsapi doc Search | API Reference | ArcGIS API for JavaScript and find enableSuggestions property. Meanwhile we will update the doc on WAB Search widget.

0 Kudos
WilliamRice
Occasional Contributor II

Jianxia,

There is nothing wrong with my ArcGIS Server 10.2 Geocoding Service.  The issue is that the javascript code for this July 2015 version of the WAB Search Widget used to generate the list of candidates is not creating a selectable area for the entire width of the Search Widget drop down area.

In anticipation of a 10.2 versus 10.3 geocoding service question, this past weekend, I created my locators using ArcGIS 10.3 software and republished the geocoding service and received the same behavior as described above.  I then also tried publishing my 10.3 Composite Locator with suggestions and the WAB Search Widget would not work at all.  My 10.2 geocoding service is fine.  The problem is this with this new javascript code that was introduced with this July 2015 update of WAB and ArcGIS Online.

0 Kudos
Jianxia
Esri Regular Contributor

OK. We will take another look.

0 Kudos
Jianxia
Esri Regular Contributor

Will, you are right. This is a bug in WAB and we have fixed it. I am able to search and click the best candidate over the text area and zoom to it.

Thanks for your help!

Jianxia