Implement support for gdbVersion property for all resources of Web App Builder in order to work better with versioned data

112
1
09-01-2022 07:49 AM
Status: Open
Labels (3)
Juliana
New Contributor II

When we have a web map application with versioned data, is it possible to create a widget to choose which version are showing in the map with API for Java Script by setting the gdbVersion property, the native Smart Editor widget already support this version changes, but the others native widgets like Attribute Table widget or Editor widget not, they are always consider only the default version, it would be great if all widgets could support changing versions in Web App Builder by working with this gdbVersion property of the versioned layer.

1 Comment
AlixVezina

Hi @Juliana ,

This is a limitation in Web AppBuilder that will not be addressed, but it is provided in Experience Builder's framework and you can switch versions of your data using the Branch Version Management widget.