Poll for updates on Feature Layer

1916
9
01-15-2013 03:40 AM
GeorgeVernardos
New Contributor III
Hello,

I am having a tough time with the "Poll for updates" option on a Feature Layer.
I can see that it creates the following line

<esriMapping:LayerExtensions.AutoUpdateInterval>30000</esriMapping:LayerExtensions.AutoUpdateInterval>

inside Map.xml, but I observe no browser activity (I would expect a post back every 30 seconds with that).
Am I missing something?

Thanks,
George Vernardos
0 Kudos
9 Replies
GeorgeVernardos
New Contributor III
At least, can anyone confirm that this feature, "Poll for updates" works correctly on a Feature Layer?

Thanks,
George
0 Kudos
GeorgeVernardos
New Contributor III
I moved up to 3.1 and the issue is still on... Can somebody please confirm that this is actually a bug?
0 Kudos
FilipJung
Occasional Contributor
Hi,
I've also tried setting up polling for updates ability on Feature Layer, but haven't been able to see it working. I used 30 seconds interval and watched Fiddler for calls, but nothing happened. So I guess this is probably a bug or maybe I'm missing something.
Thanks for help.
Filip
0 Kudos
KatherineDalton
Esri Regular Contributor
Thanks for reporting this; it appears this is broken for Feature Layers (a bug).  It should still work fine for dynamic map service layers.

Katy
Katy Dalton | Technical Consultant
THE SCIENCE OF WHERE™
0 Kudos
FilipJung
Occasional Contributor
Thanks for registering. Looking forward for a fix.
Filip
0 Kudos
HoudiniSutherland
New Contributor
Now picture this if you will:

The poll for update isn't working for feature layers (bad enough as is), which gives me no alternative but to use the other update technique (extent change). Now, as soon as I click on a feature and add it to the map (which causes the map to nudge a bit), just before I get a chance to enter data in the popup, the map refreshes (of course due to the nudge the popup caused). This of course causes all the fields on the pop up to go blank, and you can imagine why.

I could perhaps take away the auto-update feature and ask the users to refresh their pages each time they add a feature (something I would rather not do).

Could you please say when an update might be available?
This is really gett... in fact this has already gotten to me; do forgive the frustration - but I am sure you may see why I am.
0 Kudos
MichaelDice
New Contributor
Has anyone gotten this to work? It appears to still not do anything!
0 Kudos
RichZwaap
Occasional Contributor III
This issue has been fixed in version 3.2 of the Viewer, which has just been released.  Please go to the Resource Center to download it.  Sorry for the inconvenience.
0 Kudos
FilipJung
Occasional Contributor
Dear Rich,
thank you for information about updates. I have just upgraded the Viewer to 3.2 and it works great.
Best regards.
Filip

This issue has been fixed in version 3.2 of the Viewer, which has just been released.  Please go to the Resource Center to download it.  Sorry for the inconvenience.
0 Kudos