Issues with 3.1 Flex Viewer and App Builder

2107
20
12-18-2012 09:54 AM
JoshWhite
Regular Contributor III
I pulled these posts from another thread. The original posts are at http://forums.arcgis.com/threads/73572-ArcGIS-Viewer-3.1-for-Flex-released-December-13-2012?p=257627...

Yesterday 09:29 AM#2

Re: ArcGIS Viewer 3.1 for Flex released December 13, 2012



I cannot figure out what is going on. I downloaded the compiled version and the app builder for 3.1. I upgraded a test application and checked my layers. I tried to open the app in IE and while I don't get any errors, all I get is the clock symbol spinning. I also noticed that I couldn't edit the Attribute table widget in the Layout tab. In the preview tab, I get the spinning clock symbol and a bar across the screen, I assume the attribute table, when a broken image icon in the middle. Help what is going on?

Also when I click on Map Extent under the Maps tab, the application builder becomes unresponsive other than the fact that when I close it asks if I want to save any changes.


Last edited by ksjosh82; Yesterday at 09:38 AM. Reason: more info
Tags (2)
0 Kudos
20 Replies
JoshWhite
Regular Contributor III
Actually it is a layout widget.  It opens up a relate table.  I believe it is from a widget created by Robert Scheitlin.  It was written for 3.0 not 3.1 so that is probably why there is a problem now.  Which is okay, I removed it from the config file.  I wont upgrade the Application that uses it until he has the opportunity to update it.  It really is a dormant application right now so I'm in no hurry, he's pretty good about updating all of his widgets.
0 Kudos
DasaPaddock
Esri Regular Contributor
Also, in the Application Builder, you can check the log file for errors.

See the first item at this URL under "Troubleshooting":
http://resources.arcgis.com/en/help/flex-viewer/concepts/01m3/01m300000004000000.htm
0 Kudos
JoshWhite
Regular Contributor III
Ok, here is the error that showed up in the log:

12/18/2012 15:48:16.960 [FATAL] com.esri.controllers.ApplicationCompleteController Uncaught error: TypeError: Error #1009
at com.esri.ags.layers::ArcGISDynamicMapServiceLayer/loadMapImage()
at com.esri.ags.layers::DynamicMapServiceLayer/updateLayer()
at com.esri.ags.layers::Layer/updateLayerIfInvalid()
at com.esri.ags.layers::Layer/updateDisplayList()
at mx.core::UIComponent/validateDisplayList()
at mx.managers::LayoutManager/validateDisplayList()
at mx.managers::LayoutManager/doPhasedInstantiation()
at mx.managers::LayoutManager/doPhasedInstantiationCallback()


I opened up the the application and clicked Map Extent and the map displayed in the background and then a few seconds later it went white and froze up.  That is when it through this error into the log.
0 Kudos
RhettZufelt
MVP Regular Contributor
Actually it is a layout widget.  It opens up a relate table.  I believe it is from a widget created by Robert Scheitlin.  It was written for 3.0 not 3.1 so that is probably why there is a problem now.  Which is okay, I removed it from the config file.  I wont upgrade the Application that uses it until he has the opportunity to update it.  It really is a dormant application right now so I'm in no hurry, he's pretty good about updating all of his widgets.


The SearchWidgetFixedDG tag goes in the UI section of the config.xml.

Robert has already updated his widgets.  you can get the 3.1 version here:

http://www.arcgis.com/home/item.html?id=5d4995ccdb99429185dfd8d8fb2a513e

R_
0 Kudos
JoshWhite
Regular Contributor III
I also noted that I had to manually locate locator.png in the downloaded sample viewer at 3.1 and move it to my viewer to make the magnifying glass appear in the Search box.  When I type in the address using my locator, it sends me to some bizarre coordinates.  I'm using state plane and it sends me to coordinates of something like 4 -29 which as anyone knows who uses stateplane coordinates these are very bad coordinates.  An approximate coordinate of the position of the proper location is 1738537 1459908.  Using the regular locator widget, there are no issues whatsoever.

Perhaps it is expecting web mercator coordinates, I see no way to tell it otherwise?
0 Kudos
JamesFournier
New Contributor II
I just installed 3.1 on my server to replace 3.0 and am also experiencing the same issue where the map extent tab freezes and becomes unresponsive except for the ability to save the application before closing.

I set the two attributes on the map tag to false:

wraparound180="false" addarcgisbasemaps="false"  as suggested however this did not fix the problem.

I'm using state plane coordinates rather than web mercator.
0 Kudos
dawnjones
New Contributor II
I just installed 3.1 on my server to replace 3.0 and am also experiencing the same issue where the map extent tab freezes and becomes unresponsive except for the ability to save the application before closing.  I set the two attributes on the map tag to false:  wraparound180="false" addarcgisbasemaps="false"  as suggested however this did not fix the problem.

I'm using state plane coordinates rather than web mercator.


I had the same experience that Jamballya mentioned, but when I removed my local basemap service and substituted the ESRI topography map I could set map extents to operational layer extents then remove topography and add back my local basemap service.

Dawn
0 Kudos
JoshWhite
Regular Contributor III
I really wish Esri would get over its love affair with Web Mercator.  It is great for seamless nationwide/worldwide datasets but is not good for larger scales like City size (or even regional) which most of their customers work with.  Can't get the precision/accuracy that state plane offers.  I also prefer to use my own basemaps as I get to control the content.  Much of the Esri datasets are full of errors for my area.
0 Kudos
KimBülow
New Contributor III
After we have installed ArcGis Viewer for Flex 3.1, we can no longer use ESRI and bing basemap, if we do not set the two attributes on the map tag to false: as wraparound180="false" addarcgisbasemaps="false" as suggested
Then Flex 3.1 freezer ,is there another solution?, so we can use flex as in 3.0 or should we downgrade from 3.1 to 3.0?

our spatial wiki 25832 "utm 32-euref89"  is for both the dynamic layers and base maps

help needed please
Kim

our config file


<?xml version="1.0" ?>
<configuration>
    <title>ArcGIS Viewer for Flex</title>
    <logo>assets/images/logo.png</logo>
    <style>
        <colors>0xffffff,0x333333,0x101010,0x0,0xffd700</colors>
        <alpha>0.8</alpha>
        <font name="Verdana"/>
        <titlefont name="Verdana"/>
        <subtitlefont name="Verdana"/>
    </style>
    <!-- replace the following url with your own geometryservice -->
    <geometryservice url="http://tasks.arcgisonline.com/ArcGIS/rest/services/Geometry/GeometryServer"/>
    <widget url="widgets/Navigation/NavigationWidget.swf" config="widgets/Navigation/NavigationWidget.xml" left="10" top="50"/>
    <widget url="widgets/OverviewMap/OverviewMapWidget.swf" config="widgets/OverviewMap/OverviewMapWidget.xml" right="0" bottom="0"/>
    <widget url="widgets/MapSwitcher/MapSwitcherWidget.swf" config="widgets/MapSwitcher/MapSwitcherWidget.xml" right="20" top="55"/>
    <widget url="widgets/HeaderController/HeaderControllerWidget.swf" config="widgets/HeaderController/HeaderControllerWidget.xml" left="0" top="0"/>
    <widget url="widgets/Coordinate/CoordinateWidget.swf" config="widgets/Coordinate/CoordinateWidget.xml" label="Coordinate" icon="assets/images/i_globe.png" left="3" bottom="1"/>
    <map attributionvisible="true" esrilogovisible="true" openhandcursorvisible="false" scalebarvisible="true" scalebar="metric" zoomslidervisible="false" wraparound180="false" addarcgisbasemaps="false" initialextent="555007.981537702 6253127.940634368 571040.648220517 6262051.963686662" wkid="25832" top="40" portalurl="https://www.arcgis.com">
        <basemaps>
            <layer type="tiled" label="BasemapRdsHob" icon="assets/images/i_expand2.png" url="http://ags.xx.dk/gis/rest/services/Basemaps/BasemapRdsHob/MapServer" visible="true"/>
        </basemaps>
        <operationallayers>
            <layer type="dynamic" label="Varme" imageformat="png8" url="http://ags.xx.dk/gis/rest/services/Varme/Varme/MapServer" visible="true">
                <sublayer id="56" popupconfig="popups/PopUp_1.xml"/>
                <sublayer id="57" popupconfig="popups/PopUp_2.xml"/>
                <sublayer id="6" popupconfig="popups/PopUp_3.xml"/>
                <sublayer id="76" popupconfig="popups/PopUp_4.xml"/>
            </layer>
            <layer type="dynamic" label="Husnummer" imageformat="png8" url="http://ags.xx.dk/gis/rest/services/Administration/Husnummer/MapServer" visible="true"/>
            <layer type="dynamic" label="Vejnavne" imageformat="png8" url="http://ags.xx.dk/gis/rest/services/Administration/Vejnavne/MapServer" visible="true"/>
            <layer type="dynamic" label="Matrikel" imageformat="png8" url="http://ags.xx.dk/gis/rest/services/Administration/Matrikel/MapServer" visible="false"/>
        </operationallayers>
    </map>
    <widgetcontainer layout="float">
        <widget url="widgets/Draw/DrawWidget.swf" config="widgets/Draw/DrawWidget.xml" label="Draw" icon="assets/images/i_draw2.png"/>
        <widget url="widgets/Print/PrintWidget.swf" config="widgets/Print/PrintWidget.xml" label="Print" icon="assets/images/i_print.png"/>
        <widget url="widgets/eDraw/eDrawWidget.swf" config="widgets/eDraw/eDrawWidget_1.xml" label="Enhanced Draw Widget" icon="widgets/eDraw/assets/images/i_draw.png"/>
        <widget url="widgets/eMapSwitcher/eMapSwitcherWidget.swf" config="widgets/eMapSwitcher/eMapSwitcherWidget_1.xml" label="eMapSwitcher" icon="assets/images/i_widget.png"/>
    </widgetcontainer>
    <widgetcontainer paneltype="bottom" initialstate="collapsed">
        <widget url="widgets/AttributeTable/AttributeTableWidget.swf" config="widgets/AttributeTable/AttributeTableWidget.xml" label="Attribute Table" icon="assets/images/TableOpen32.png"/>
    </widgetcontainer>
</configuration>
0 Kudos
BjornSvensson
Esri Regular Contributor
There is currently a known limit when working with maps that do not use either Geographic or Web Mercator for their basemap's spatial reference. If you are using a spatial reference other than this, you will need to set the config.xml map's wraparound and addarcgisbasemaps attributes to 'false'.

-- from http://resources.arcgis.com/en/help/flex-viewer/concepts/index.html#//01m300000011000000#GUID-82B3FE...

Kim,
It's correct that you have to set those two parameters, do you still have problems after doing that?

As for other solutions:
If you are compiling the source yourself, the code is available on GitHub to work around this.
Or you can wait for the next release, version 3.2, which among other things will add supports for 6 new locales, including Danish. We're planning to release 3.2 at the end of March.
Or you can use the previous (3.0) version.
0 Kudos