Utility Network Enterprise version downgrade

454
5
Jump to solution
08-12-2021 01:05 PM
LindseyStone
Occasional Contributor III

When deploying the newest Electric Utility Network Enterprise v1 asset package it appears that it was created in Pro 2.7 which puts it at V5 and only compatible with Enterprise 10.9.  I have Enterprise 10.8.1 and running Pro 2.6 so my utility networks are in V4 for the 10.8.1 Enterprise compatibility.

Is there a way to downgrade or drop the asset package to V4 that Pro 2.6 can recognize to be able to apply to the Enterprise 10.8.1 server environment?  If not that any user not on Enterprise 10.9 can not utilize the Electric Utility Network Enterprise package and are forced to use the Electric Network Foundation packages which have already been moved to mature support. 

0 Kudos
1 Solution

Accepted Solutions
LindseyStone
Occasional Contributor III

In Electrical I had to delete Object ID 15, 16, and 17.  Once I did this the tool ran just fine and downgraded the EnterpriseV1 to a utility network v4 to be able to work on Pro 2.6 and Enterprise 10.8.1

View solution in original post

0 Kudos
5 Replies
RandallChew
Occasional Contributor

Lindsey, we are in the same boat as well with another project but with Water and Sewer.  While we were planning for a water deployment a new sewer solution was released with Pro 2.7 which will only work with 10.9.  We are thinking we may just build a UN from scratch with Pro 2.6 to put it at V4.  We will then copy the guts out of the new data model and move forward from there.  A lot of the dependencies seem to lie with the attribute rules which we've started deleting anyway from the asset package as they can slow down load times and usability times drastically.  We then add in what we need depending on the need.  If you can get this figured out please let me know.  We've tried every approach less the total build out of a UN from scratch.  I hope it doesn't come to that...

0 Kudos
RandallChew
Occasional Contributor

Hey Lindsey.

Try this workflow.  A colleague with 1898 showed it to us and it took a V5 and brought it down to a v4.

  • Copied the asset package with UN v5 on to a machine using Pro 2.6.
  • Ran Asset Package to File Geodatabase to build a UN GDB. Confirmed the version was v4.  Use the GP tool, Asset Package to File Geodatabase. 
  • Ran Export Asset Package to create the asset package GDB attached.

This worked for us.

LindseyStone
Occasional Contributor III

When running that tool with the electric utility network enterprise v1 I receive the below error message

LindseyStone_0-1629150135337.png

 

0 Kudos
RandallChew
Occasional Contributor

Lindsey,  can you try removing rows with object ID 15 and 16 and see if it works?  Maybe those rules have a dependency on something that has to be there that isn't when you export to a v4?

You can manually add them in (if you need them) after it loads into a UN.  

0 Kudos
LindseyStone
Occasional Contributor III

In Electrical I had to delete Object ID 15, 16, and 17.  Once I did this the tool ran just fine and downgraded the EnterpriseV1 to a utility network v4 to be able to work on Pro 2.6 and Enterprise 10.8.1

View solution in original post

0 Kudos