Select to view content in your preferred language

Update data source tool

780
4
Jump to solution
09-16-2023 11:52 PM
ShamsMoaied
New Contributor III

Dear Community 

I'm attempting to update the data source of the map to a feature service, but an error has occurred.

Tags (3)
0 Kudos
1 Solution

Accepted Solutions
MikeMillerGIS
Esri Frequent Contributor

Can you also post a picture of the UtilityDataManagement Supprot toolbox?  I search the source code and cannot find the sde_to_branch function.  Maybe this is a really old version.  We have newer versions here - https://esri.github.io/Utility-Data-Management-Support-Tools/

View solution in original post

0 Kudos
4 Replies
MarceloMarques
Esri Regular Contributor

You need to remove the map layer and add a new layer using the feature service.

| Marcelo Marques | Principal Product Engineer | Esri |
| Cloud & Database Administrator | OCP - Oracle Certified Professional |
I work with Enterprise Geodatabases since 1997.
“ I do not fear computers. I fear the lack of them." Isaac Isimov
0 Kudos
MikeMillerGIS
Esri Frequent Contributor
Can you copy the python call so I can see all the parameters?

What version of Pro?

Can you post a picture of the TOC of the map?
0 Kudos
MikeMillerGIS
Esri Frequent Contributor

Can you also post a picture of the UtilityDataManagement Supprot toolbox?  I search the source code and cannot find the sde_to_branch function.  Maybe this is a really old version.  We have newer versions here - https://esri.github.io/Utility-Data-Management-Support-Tools/

0 Kudos
ShamsMoaied
New Contributor III

Thanks for the reply.

After a couple of tries, the tool finally worked correctly using the latest update, version 3.1

 

 

 

 

 

 

 

0 Kudos