Why does my published survey have a json error when I try to download it?

1696
11
Jump to solution
07-19-2019 09:29 AM
CarbonCounty_Utah
New Contributor III

I tried to download a published survey today that is being actively used, and received the following message: /var/mobile/Containers/Data/Application/F4951702-56DE-42F0-A204-534544DD5DF4/Documents/ArcGIS/My Surveys/d2111ba4e4d6480ca1f1afde95d2fd94/forminfo.json not found. The survey has not been edited since I initially published it, so I'm confused as to why I'm receiving this when I attempt to download it onto a device. I currently have assessors collecting data in the field with the survey, so I'm also concerned that we're going to run into issues. Does anyone know what generated this error and how to fix it?

0 Kudos
1 Solution

Accepted Solutions
CarbonCounty_Utah
New Contributor III

Republishing from Connect worked. I was able to download the survey on both devices without the json error, and none of the data collected was lost. Thank you for your help, Philip!

View solution in original post

11 Replies
Philip-Wilson
Esri Notable Contributor

Hi there,

It sounds as though when the survey Form item is being unpacked on the device that the forminfo.json file is missing.

What device make/model/OS are you using? Does the same survey work ok when downloaded on other devices?

Are you able to navigate to the folder ~/ArcGIS/My Surveys/d2111ba4e4d6480ca1f1afde95d2fd94/ and see if there is a *.json file in that folder?

Phil.

0 Kudos
CarbonCounty_Utah
New Contributor III

Thanks for the response! I've tried downloading the survey onto an iPhone and mini iPad. Both devices gave me the same error. The survey was created and published from Survey123 Connect. After the error started popping up, I downloaded the published survey into connect, and there is a .json file in the folder. Should I attempt to republish it? I'm concerned that if I do, I'll lose about 700 points that my assessors collected.

0 Kudos
CarbonCounty_Utah
New Contributor III

I tried downloading on an iPhone 8 and a 5th generation iPad mini. Both have Software Version 12.3.1.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Provided you do not make any changes to the survey in Connect, simply download the latest version from Online/Portal in the latest Connect version (use the re-download survey arrow/cloud on the survey tile once you sign in), and then simple re-publish the survey, it will re-create the form item in your Online/Portal account, but it will not delete or affect any of the existing data. You will get a warning if there are any schema or compatibility issues, so in that case do not continue with the republish.

Phil.

CarbonCounty_Utah
New Contributor III

Republishing from Connect worked. I was able to download the survey on both devices without the json error, and none of the data collected was lost. Thank you for your help, Philip!

DeonLengton
Esri Contributor

Hi Philip

All of a sudden I am also struck with this forminfo.json error.

I checked on Connect and the file is not even created in the survey source folder at all.

I copied the same survey to another one and still same issue.

Any ideas? I am on the latest Connect.

If I manually create the forminfo.json file everything seems to be working fine 

0 Kudos
JoeLapka
New Contributor

One of my field evaluators experienced the same issue today. For now the issue appears to be limited to his (Android) device because I was able to download/refresh the survey on other iOS and Android devices and it works as expected on those devices.

0 Kudos
Philip-Wilson
Esri Notable Contributor

Hi Joe,

What was the make/model/OS version of the Android device that had an issue?

Phil.

0 Kudos
JoeLapka
New Contributor

Hi Philip, thanks for your reply. It is a Motorola G5 Plus running Android 8.1.0/OPSS28.85-17-6. He successfully downloaded and opened the survey in question a couple weeks ago. I made a couple of changes to the survey recently and this issue started when he tried to refresh the survey. It looks like it downloads ok and starts unpacking the contents but then this message appears. The device has an SD card for storage and I get the feeling the forminfo.json file is being unpacked in one location but Survey123 is looking for it in a different location.

0 Kudos