Webhook not being triggered from Webform

274
2
08-24-2022 05:47 AM
AndrewBowne
Occasional Contributor III

We've been having some problems with Make (Integromat) webhooks not being triggered from a webform.  However, they are triggered if you use the mobile app.  I checked DevTools and noticed that it appears to be a CORS policy that is being blocked.  Any idea how to resolve this?

AndrewBowne_0-1661345266041.png

 

 

0 Kudos
2 Replies
ZacharySutherby
Esri Regular Contributor

Hello @AndrewBowne

I'm not seeing this issue on my end with a test survey. A few questions I have are: 

- Is your survey hosted in ArcGIS Online or ArcGIS Enterprise? 

- Do you have a region set in your Make account?

    - For example I have my region set to US

ZacharySutherby_0-1661961540120.png

 

- Does this happen for multiple different surveys or just one specific survey? 

Thank you,
Zach
0 Kudos
AndrewBowne
Occasional Contributor III

Hi Zach,

This survey is hosted on our ArcGIS Enterprise (10.9.1)

I haven't made the migration from Integromat to Make yet so I'm not sure where you check your region in Integromat.  I did find this:

AndrewBowne_0-1661964904356.png

 

This has proven to be a very interesting problem.  It only happens with this specific survey and it does not happen with all records that are submitted.  It seems to be hit-or-miss.  It only seems to happen when using the Webform.  If I add or edit a survey with the field app, the webhook is triggered every time.  

I did some testing where I had the user reporting the issue log in to my ipad and submit a record.  It worked.  I then went and tried editing the survey on the webform.  It worked.  

I then logged on his ipad and submitted a record, it worked.  He went and edited my record in the webform and it worked.

So, there seems to be no rime or reason.  Some records work and some don't.  What is consistent is the records that don't work... never trigger the webhook from the webform when trying to update.  

Is there something specific in the data that would cause this?

 

Thanks,
Andrew

0 Kudos