Webform pages not displaying correctly with Back button

267
4
Jump to solution
10-01-2021 03:38 PM
AmyBethCalahan
New Contributor II

I have a webform, designed in Connect, that uses the pages style, with 19 pages total.

When users go through the survey, and then select the Back button to go to previous pages, the Page...of... display does not update to the page the user backed up to.

Has anyone else experienced this?  I'm not sure if this is just a webform bug/behavior or something in my survey causing webform confusion.

This is an example of what should be page 11 of 19, not 19 of 19

AmyBethCalahan_0-1633127749546.png

Thanks!

0 Kudos
1 Solution

Accepted Solutions
Philip-Wilson
Esri Frequent Contributor

Hi @AmyBethCalahan,

Thanks for sharing your xlsx file. I published the survey form with Connect 3.13 and opened in the Survey123 web app, and can not reproduce the issue. I see all pages working as expected, can navigate to page 8 and back to page 1, and see the correct page numbers always. Looking at the xlsx file, I don't see any issues that would cause this type of problem with page number labels in the web app.

Which version of Connect did you publish this survey from, have you re-published it recently with latest 3.13 builds?

Do you have version locking enabled in the website settings for this survey?

PhilipWilson_0-1633399634895.png

 

Which browser are you using, what version, and have you tried clearing the cache or use a different browser in private/incognito mode, and see if issue still occurs?

If you want me to also test out your longer 19 page survey, you can send me the xlsx file via private message, to not share it publicly on this post. Just click on my username and from my profile you can select direct message.

Regards,

Phil.

View solution in original post

0 Kudos
4 Replies
Philip-Wilson
Esri Frequent Contributor

Hi @AmyBethCalahan,

Can you please share your XLSForm (xlsx file and media folder) that you created in Connect? That way we can take a look and see what the cause is, if it is an issue with webform or how your form is configured.

Regards,

Phil.

0 Kudos
AmyBethCalahan
New Contributor II

Hey Phil,

Thank you for your super speedy response!  I've attached an abbreviated version of the survey, as some content in the original survey is restricted/protected by my agency.  This shorter form has the same page number behavior as the long form (and will spare you from searching through an 18 page lengthy survey). 

I just attached the xlsx, as there are no media files associated with the survey.  We're still going to roll out the survey regardless, but just wanted to see if there is an 'easy' fix to avoid any potential user confusion.

Thanks for taking the time looking into this!

0 Kudos
Philip-Wilson
Esri Frequent Contributor

Hi @AmyBethCalahan,

Thanks for sharing your xlsx file. I published the survey form with Connect 3.13 and opened in the Survey123 web app, and can not reproduce the issue. I see all pages working as expected, can navigate to page 8 and back to page 1, and see the correct page numbers always. Looking at the xlsx file, I don't see any issues that would cause this type of problem with page number labels in the web app.

Which version of Connect did you publish this survey from, have you re-published it recently with latest 3.13 builds?

Do you have version locking enabled in the website settings for this survey?

PhilipWilson_0-1633399634895.png

 

Which browser are you using, what version, and have you tried clearing the cache or use a different browser in private/incognito mode, and see if issue still occurs?

If you want me to also test out your longer 19 page survey, you can send me the xlsx file via private message, to not share it publicly on this post. Just click on my username and from my profile you can select direct message.

Regards,

Phil.

View solution in original post

0 Kudos
AmyBethCalahan
New Contributor II

Hey Phil,

Thank you so much -- it's working properly now.  I think my new mantra is "upgrade to the latest build and see if that helps first", haha!

Again, I appreciate your speedy response and assistance!