Unable to Enable Editing, Survey123 feature layer

306
2
01-05-2021 01:45 PM
SarahSchwarzer1
New Contributor II

Edit for clarity:

I want to edit a hosted feature layer that was generated for Survey123 and am not able to enable editing. I get this message when I attempt to:

Unable to load https://[us]/portal/sharing/proxy?https://arcgis.[us].gov:6443/arcgis/rest/admin/services/Hosted/service_858bcd8d366241c79c8d406afab98... status: 500

I am trying to make the change using the portal website on the Settings tab for the feature layer.

enable editing.PNG

 

 

Original post with lots of unnecessary info:

We want to publish a survey that has a few hidden fields that we can edit through ArcMap 10.5.1. (We want to collect some information from people and then store fields for internal use that tell us who's working on that record, etc.)

I have published a survey through our Portal account with sufficient permissions, and had it create a hosted service - we don't need or want to manage it in SDE. I did not see any options during publishing and am not able to later change the settings on the service to allow editing. I get this error:

Unable to load https://[us]/portal/sharing/proxy?https://arcgis.[us].gov:6443/arcgis/rest/admin/services/Hosted/service_858bcd8d366241c79c8d406afab9862b/FeatureServer/updateDefinition  status: 500

This is through the Portal/home site and not admin, because I'm not very familiar with the latter. I did check if there were any errors/warnings in the logs when I tried to make those changes and there were none.

I also see that the service is called a "Feature Layer" and not "Feature Service," and I had thought only the latter were editable. I don't see a way to CREATE a feature service on publication, though. I supposed I could write the service first and then create the survey on top of it, but that seems like a lot of extra work so I'm thinking I'm missing something.

I see that I may face some workarounds when I DO finally make this editable, such as having to store a local copy and then sync it. I've also seen something about folks having an issue with "WebContextURL" but that is beyond me. Before I jump down that rabbit hole I was hoping someone can point me in the right direction, and then I will learn what I need to learn to fix it.

Thank you!

0 Kudos
2 Replies
DougBrowning
MVP Notable Contributor

I am a bit confused as 123 does create a feature service when you publish it along with a form item.  It should say Feature Layer (hosted).  Yes you can edit it after.  You are going to want to use ArcPro though.  Way easier - no check in/out.  We do it all the time.  I have not ever published to Portal however.  

I know that does not help much just wanted to say go Durham GIS!

0 Kudos
SarahSchwarzer1
New Contributor II

Hello Doug! I am not able to select and save the "Enable editing" option on the feature service. That is the issue I am having.

And yes, I'd love if we could all use ArcGIS Pro, but we're not there yet!

0 Kudos