Surveys submitted through a tablet or phone offset date by -1

103
4
Jump to solution
08-01-2019 04:01 PM
Highlighted

I've tried using the browser tool and survey123 connect to create a survey but each time I want to fill it out using a browser on the ipad or an iphone the date gets offset by -1 day once submitted. If the survey is filled out through the mobile app or a desktop browser the date gets saved correctly. Any suggestions?

Reply
0 Kudos
1 Solution

Accepted Solutions
Highlighted
Esri Regular Contributor

Hi Anthony,

I was able to repro the same using Safari on iOS devices and it seems to be an issue specific to this browser. I had entered an issue for this and thanks for reporting this. Please continue to use the workaround by creating datetime type of question till we resolve this issue.

View solution in original post

4 Replies
Highlighted
Esri Regular Contributor

Hi Anthony,

What version of Survey 123 Connect you are using? We recently fixed a date issue on Connect and the issue you described should be the one we fixed with 3.5 release. Could you try again with 3.5 release to see if you are still seeing the offset date?

Reply
0 Kudos
Highlighted

I updated and issue is still present. I found a work around by changing the type from date to dateTime.

Reply
0 Kudos
Highlighted
Esri Regular Contributor

Hi Anthony,

I was able to repro the same using Safari on iOS devices and it seems to be an issue specific to this browser. I had entered an issue for this and thanks for reporting this. Please continue to use the workaround by creating datetime type of question till we resolve this issue.

View solution in original post

Highlighted

I also tested using Google Chrome on an iPhone and was still getting the same issue. In the meantime the work around will work for me but it would be nice if ESRI could resolve this in the future. Thanks for looking into this for me.

Reply
0 Kudos