Survey123 grid theme issues

1170
2
12-17-2019 12:37 PM
by Anonymous User
Not applicable

Hello, 

I have a rather long survey123 form and I have been playing with the Theme Grid to try and make the survey more compact. I have recently updated to the 3.7.60 version of survey123 Connect, but i am still having the same issues. I have changed the style to theme-grid and I have seen the changes in my survey. Problem now is that I would like to make some groups a different size (appearance) than other groups. i would like a grid that is w3 and another group that is only w2. When I go to change the appearance of a group I get an error message (see attached photo) that tells me I have enter a invalid value. It will not accept any changes to the appearance that are not from the drop down list. Has anyone else had these issues? I would imagine that I need to make some small change to get everything to work but I cannot figure it out. Does anyone have any advice? 

0 Kudos
2 Replies
Jim-Moore
Esri Regular Contributor

Hi Michael

Sounds like this is being caused by the data validation on the appearance cell (or column). You could try selecting the appearance column, then removing the data validation by setting it to allow any value (data validation settings are on the Data ribbon in newer versions of Excel). Note that this will remove the drop-down options (however, as as reference all available appearances are listed on the types sheet). Alternatively, you could download the latest advanced XLSForm template in Connect as a starting point and build your survey from here; the advanced template has data validation rules for certain columns to assist you with your selections, but it should allow you to override the rule after displaying a warning.

Some handy info on grid theme available here: 

https://community.esri.com/groups/survey123/blog/2019/11/20/survey123-tricks-of-the-trade-groups-gri... 

Appearance—Survey123 for ArcGIS | Documentation 

Best,

Jim

by Anonymous User
Not applicable

Jim,

Thank you very much, changing the data validation settings fixed everything for me. I appreciate the quick response

Cheers!