survey123 globalId is not retrieving

1225
4
09-02-2020 11:43 AM
DongliangLi
New Contributor

Hi,

I am using Integromat to create a webhook to connect my survey in Survey123.

My main goal is to allow the survey taker to be able to return to their survey if they are not finished at the first place. 

I was able to set up the scenario to send out the email to the recipients. However, when the recipient clicks the link and direct them to the Survey123 site, it will come up with an error saying: "Editing is not possible because the record specified by the globalId parameter cannot be found."

Here is the content I input in Integromat: 

I was following this article: https://community.esri.com/groups/survey123/blog/2019/05/24/survey123-tricks-of-the-trade-editing-re... to implement this method, but I want the user to be able to see the whole link not the TO GO Link that's why I did not use <a href ="........."> </a ...>. 

Any comments is going to be help. 

Thanks. 

0 Kudos
4 Replies
Jim-Moore
Esri Regular Contributor

Hi Dongliang Li

From your screenshot, it looks like the URL is constructed correctly. The error you're seeing occurs when the globalID does not exist in your feature layer. Which module are you using in Integromat to send the email? When the recipient clicks on the link, what does the URL look like in the browser? It should look something like this:

https://survey123.arcgis.com/share/a5025646ddf54b88b11b754cac402171?mode=edit&globalId=%7bE7E44987-E...

 

Or this:

https://survey123.arcgis.com/share/a5025646ddf54b88b11b754cac402171?mode=edit&globalId={E7E44987-E1F...

Best,

Jim

0 Kudos
DongliangLi
New Contributor

Hi,

The URL looks like the second one you put it out.

And this time it seems like I can retreat the previously input but I am running into another problem that I can't submit it because a "No permission to edit the specified feature." error message. 

Here are my  Survey123 Web platform settings:

This is the setup in Intergromat.

Thanks

0 Kudos
Ruth_JiatengXu
Esri Contributor

Hi Dongliang,

Sorry for the late reply.

Since you have the setting "what data can viewers see? Only their own submitted record", the non-owner user will only be able to edit the record that submitted by themselves. 

If this was the case, could you please double-check the account and the record that you used for testing?

Thanks,

Ruth

DanielMyers
New Contributor II

I believe that you either have to go to your feature service > visualization > configure pop up attributes > and make sure globalID is set to display OR in your embedded content make sure that the 'layer' you've selected is the same layer you're trying to filter on. 

0 Kudos