Survey123 failed to export data to Excel when filtering one specific field

349
2
05-04-2020 10:20 PM
elisapuccioni
New Contributor II

Hi all,

I'm running into a strange problem. I have a survey (now closed) that was created from a feature service in Connect. I can view and analyse all the records and I can also view and filter the data in the Data panel. I can export the data, all of them or filtered by any of the field in the Survey. Well any except one. When I filter by that field, I can view/query/select the data but when I export them to Excel or csv the spreadsheet is empty, showing only the field names.

If I export the file to a geodatabase I can see the records.

That field was mistakenly created with a / in the label in the xml form, but that error has been corrected and all has been refreshed. Moreover, not sure if important, it's the only field that got populated from a multiple choice question.

I'm a loss of ideas, as I've tried all...any help on this? It would be greatly appreciated!

0 Kudos
2 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Elisa,

Could you go to the Item Details of the feature service and see if the field's display name is also updated (by default, it would not have been)?  Updating that in the feature service and/or stakeholder view should resolve the issue.

0 Kudos
elisapuccioni
New Contributor II

Hi James,

thanks for your reply! I've double checked both the feature layer and the stakeholder view and both had already the display name updated to the correct one...but still no luck in exporting the data when I filter that field in the Survey123 Data section...any other thing that I might be missing? This problem is really puzzling me!

Cheers,

Elisa

0 Kudos