Survey123 export issues since Dec release (AWS issue...)

12-13-2021 02:57 AM
Occasional Contributor III

Hi all,

has anyone else had any issues with the Survey123 website since the December update / AWS issue?

we have a few surveys but one of them is having issues with exporting the total parent records of that survey is just over 110,000 and has 8 related features & tables class's, if i filter for surveys updated over the last 1 day ( a few hundred ) and then go to export and try to export it to excel it just sits there for hours doing nothing

we have an idential survey in terms of questions / related features / tables but with only 5,000 parent records and i can export from that without issue

we've got an ESRI case open but just wanted to see if anyone else has had the same issues with large surveys

2 Replies
Occasional Contributor III

Hi @StuartMoore , yes this is a widescale issue not just with ESRI surveys. Audible, email services, weather apps, and many ESRI systems like dashboards and AGOL all draw from the AWS system at some point, (which crashed/froze last Tuesday) and are all experiencing serious issues. Be it connectivity, extended glitches, temporary loss of function or tools, etc. I know there's at least two other cases open as well on our end, usually completely purging temporary files and caches has helped but the issues persist. Up to Tuesday the 7th, the update for December worked great, but with the sudden system wide glitch or crash there have been a number of issues that are ongoing and the recovery has been hit or miss just with the glitches. Have you had any feedback for resolutions, fixes, or workarounds until a new system update can be made?

Best regards, God bless & Merry Christmas,


Jansen Lyons - Records and GIS Section - Public Works - City of Rio Rancho, NM
Occasional Contributor III

hi @GIS_Fox, we've not had anything back from them yet, i did try a few workarounds to get the data, you can export it from ArcGIS Pro using "table to excel" and also managed to do something very crude in AGOL Notebooks, lastly just tried Data Interopability in Pro and that also worked

but none are the best solution as its me having to run them rather than the usual team

i'll post an update if i do hear anything