Survey123 Error - Field Name Collision Found

404
3
12-06-2019 07:17 AM
RyanUthoff
Occasional Contributor III

I am trying to republish an already existing Survey123 in ArcGIS Enterprise. All I did was add a new field to the survey called "survey_version" and when I try to republish it, I get the following error message: ERROR: Field name collision found: survey_version." Error code: 500.

Any thoughts on what could be causing this error message? I've been able to re-publish other forms with the exact same field name and haven't had any issues.

0 Kudos
3 Replies
JamesTedrick
Esri Esteemed Contributor

Hi Ryan,

Is there another field named 'survey_version' (possibly different capitalization) in the feature service?  The error message is indicating that it cannot add the field as there is already one with that name.

0 Kudos
RyanUthoff
Occasional Contributor III

Hello,

That's what I was thinking. But there are no fields named 'survey_version'. I checked both the excel document and the hosted feature service and no fields exist with that name. Furthermore, when I click the Publish button in Survey123, it gives me a warning that the survey has already been published and that one field was not found in the feature service, which is 'survey_version'. So it definitely appears that it does not previously exist. I'm assuming the solution would be to just create a new Survey123 form. But I was hoping to avoid going that far to fix the problem.

0 Kudos
RyanUthoff
Occasional Contributor III

Just to update, I checked the underlying PostgreSQL database of the hosted feature service and the base table contains the 'survey_version' field, but the view does not contain it. I'm just going to publish a brand new Survey123 form.

0 Kudos