survey123 connect installation error

200
3
Jump to solution
11-25-2020 01:28 AM
Labels (1)
Occasional Contributor II

Hi, I try to install survey123 connect on my (managed and virtualizes) windows10 workstation. Installation is ok untill 96% when I get this:

BertKraan1_0-1606296015824.png

Something about a desktop shortcut not being able to be written, doesn't seem like a big deal. I can find the executable myself but when I start it I only get a small empty window without anything in it. registrykeys are being written.

My IT dept can install it without errors, we get a desktop shortcut then but the same empty window as a result.

Anyone any ideas on what to do now? I'm using Survey123Connect_x64_3_11_123 but 32bit same result...

 

thanks for your time,

Bert

 

ps sorry for using the announcement label but that seems the only one available to me??

 

Reply
0 Kudos
1 Solution

Accepted Solutions
Esri Frequent Contributor

Hi Bert,

Unfortunately we no longer support Windows Server 2012. The minimum server version we support now is 2016.

Please see the system requirements documentation for all supported operating system versions: https://doc.arcgis.com/en/survey123/faq/systemrequirements.htm#ESRI_SECTION1_5C924E609FBC4F6683B5FB9...

The issue you are seeing on Server 2012 R2 is expected as it uses drivers and system configurations we no longer support.

Regards,

Phil.

View solution in original post

Reply
0 Kudos
3 Replies
Esri Frequent Contributor

Hi Bert,

What exact version of Windows 10 is the VM running? Please check in the System - About screen and provide the Edition, Version and OS Build.

What virtualization software is the VM running on, Hyper-V or VMware or other?

Do you have administrator rights on the VM, or just a standard user?

And lastly, the small white window that opens usually points to a graphics driver issue. Either that or a bluetooth driver issue. Can you try and run the app from the command line, using the different graphics options of OpenGL and Angle.

https://doc.arcgis.com/en/survey123/faq/faqgeneral.htm#anchor14

You need to put the path to the .exe in the install folder in command window, and then followed by --renderingEngine angle or --renderingEngine opengl.

Let me know the results and answers to above questions.

Regards,

Phil.

 

Reply
0 Kudos
Occasional Contributor II

Hi Phil,

It turns out my virtualized desktop is not windows10 at all, it says windows server 2012 r2 standard.

"winver" returns ms windows server 6.3 build 9600, so perhaps this OS is not supported at all?

 

We use VMWare as virtualization platform.

I have elevated rights, normally I can install new software without problems. I had an IT admin install survey123 connect with the same results (except for the desktop shortcut which he could, and i could not write)

The parameters have no visible effect:

BertKraan1_0-1606377225822.png

thanks for your time,

 

Bert 

 

 

Reply
0 Kudos
Esri Frequent Contributor

Hi Bert,

Unfortunately we no longer support Windows Server 2012. The minimum server version we support now is 2016.

Please see the system requirements documentation for all supported operating system versions: https://doc.arcgis.com/en/survey123/faq/systemrequirements.htm#ESRI_SECTION1_5C924E609FBC4F6683B5FB9...

The issue you are seeing on Server 2012 R2 is expected as it uses drivers and system configurations we no longer support.

Regards,

Phil.

View solution in original post

Reply
0 Kudos